summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-08 21:02:50 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-08 21:02:50 +0000
commit666a46f9fc9a4bce957ee98a526f61aafe765518 (patch)
treec52a8f33c43110211b6710068d3be82492c346cb /app-editors
parentminor change (diff)
downloadhistorical-666a46f9fc9a4bce957ee98a526f61aafe765518.tar.gz
historical-666a46f9fc9a4bce957ee98a526f61aafe765518.tar.bz2
historical-666a46f9fc9a4bce957ee98a526f61aafe765518.zip
minor changes
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/ChangeLog11
-rw-r--r--app-editors/jedit/jedit-4.0.3.ebuild24
-rw-r--r--app-editors/jedit/jedit-4.0.ebuild18
-rw-r--r--app-editors/pico/ChangeLog11
-rw-r--r--app-editors/pico/pico-0.0.1.ebuild6
5 files changed, 44 insertions, 26 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index e93a9b096c3d..3015d50d38d1 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-editors/jedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.2 2002/07/02 17:53:57 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.3 2002/07/08 20:58:44 blizzy Exp $
*jedit-4.0.3 (02 Jul 2002)
@@ -12,9 +12,6 @@
*jedit-4.0 (09 Jun 2002)
09 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+
+ Initial import, closes bug #3152.
+ ebuild submitted by Maik Schreiber <bZ@iq-computing.de>
diff --git a/app-editors/jedit/jedit-4.0.3.ebuild b/app-editors/jedit/jedit-4.0.3.ebuild
index edcfc947232b..7e30b71fa37a 100644
--- a/app-editors/jedit/jedit-4.0.3.ebuild
+++ b/app-editors/jedit/jedit-4.0.3.ebuild
@@ -1,20 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author: Maik Schreiber <bZ@iq-computing.de>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3.ebuild,v 1.1 2002/07/02 17:53:57 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3.ebuild,v 1.2 2002/07/08 21:02:50 blizzy Exp $
S="${WORKDIR}/jEdit"
DESCRIPTION="Programmer's editor written in Java"
HOMEPAGE="http://www.jedit.org"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
LICENSE="GPL-2"
-DEPEND=">=dev-java/ant-1.4.1 >=dev-java/jikes-1.15"
+SLOT="0"
+KEYWORDS="*"
+
RDEPEND=">=virtual/jdk-1.3"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.15 )"
src_compile() {
- einfo "Please ignore the following compiler warnings."
- einfo "Jikes is just too pedantic..."
- ant -Dbuild.compiler=jikes || die "compile problem"
+ local antflags
+
+ antflags=""
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+
+ ant ${antflags} || die "compile problem"
}
src_install () {
diff --git a/app-editors/jedit/jedit-4.0.ebuild b/app-editors/jedit/jedit-4.0.ebuild
index 5de60abc6d7f..c5213ee4ea7c 100644
--- a/app-editors/jedit/jedit-4.0.ebuild
+++ b/app-editors/jedit/jedit-4.0.ebuild
@@ -1,17 +1,27 @@
# Copyright 2002 Maik Schreiber
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.ebuild,v 1.1 2002/06/10 01:30:58 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.ebuild,v 1.2 2002/07/08 21:02:50 blizzy Exp $
S="${WORKDIR}/jEdit"
DESCRIPTION="A programmer's editor written in Java"
HOMEPAGE="http://www.jedit.org"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit40source.tar.gz"
LICENSE="GPL-2"
-DEPEND=">=dev-java/ant-1.4.1 >=dev-java/jikes-1.15"
+SLOT="0"
+KEYWORDS="*"
+
RDEPEND=">=virtual/jdk-1.3"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit40source.tar.gz"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.15 )"
src_compile() {
- ant -Dbuild.compiler=jikes || die
+ local antflags
+
+ antflags=""
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ ant ${antflags} || die "compile problem"
}
src_install () {
diff --git a/app-editors/pico/ChangeLog b/app-editors/pico/ChangeLog
index db6b422121e1..83b9bce680fc 100644
--- a/app-editors/pico/ChangeLog
+++ b/app-editors/pico/ChangeLog
@@ -1,13 +1,10 @@
# ChangeLog for app-editors/pico
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/ChangeLog,v 1.1 2002/06/10 01:24:55 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/ChangeLog,v 1.2 2002/07/08 20:56:35 blizzy Exp $
*pico-0.0.1 (09 June 2002)
09 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+
+ Initial import, closes bug #3464.
+ ebuild submitted by Maik Schreiber <bZ@iq-computing.de>
diff --git a/app-editors/pico/pico-0.0.1.ebuild b/app-editors/pico/pico-0.0.1.ebuild
index 32c447cf6ee9..ea919821aea7 100644
--- a/app-editors/pico/pico-0.0.1.ebuild
+++ b/app-editors/pico/pico-0.0.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Maik Schreiber <bZ@iq-computing.de>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/pico-0.0.1.ebuild,v 1.1 2002/06/10 01:24:55 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/pico-0.0.1.ebuild,v 1.2 2002/07/08 20:56:35 blizzy Exp $
HOMEPAGE="http://www.washington.edu/pine"
DESCRIPTION="Pico text editor"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="*"
pkg_setup () {
einfo "There is no real Pico here."