summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 10:23:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 10:23:30 +0000
commit4411a04a83d046ebe1bf93cfcc5764f7572ec66e (patch)
tree0db5b51dea919b71f1a00d5e22324ee701af43ab /app-editors
parentBump (diff)
downloadhistorical-4411a04a83d046ebe1bf93cfcc5764f7572ec66e.tar.gz
historical-4411a04a83d046ebe1bf93cfcc5764f7572ec66e.tar.bz2
historical-4411a04a83d046ebe1bf93cfcc5764f7572ec66e.zip
Bump
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/fe/ChangeLog9
-rw-r--r--app-editors/fe/fe-1.9.ebuild39
-rw-r--r--app-editors/ne/ChangeLog9
-rw-r--r--app-editors/ne/ne-2.3.ebuild47
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-32.0.0.ebuild48
6 files changed, 154 insertions, 5 deletions
diff --git a/app-editors/fe/ChangeLog b/app-editors/fe/ChangeLog
index cc2cd84085e8..5cace064e64e 100644
--- a/app-editors/fe/ChangeLog
+++ b/app-editors/fe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/fe
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/ChangeLog,v 1.8 2011/08/27 19:12:54 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/ChangeLog,v 1.9 2012/03/16 10:14:35 patrick Exp $
+
+*fe-1.9 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +fe-1.9.ebuild:
+ Bump
27 Aug 2011; Ulrich Mueller <ulm@gentoo.org> -files/fe-1.6-nostrip.patch,
fe-1.8.ebuild, +files/fe-1.8-makefile.patch:
diff --git a/app-editors/fe/fe-1.9.ebuild b/app-editors/fe/fe-1.9.ebuild
new file mode 100644
index 000000000000..bb22e0f7b5e3
--- /dev/null
+++ b/app-editors/fe/fe-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/fe-1.9.ebuild,v 1.1 2012/03/16 10:14:35 patrick Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A small and easy to use folding editor"
+HOMEPAGE="http://www.moria.de/~michael/fe/"
+SRC_URI="http://www.moria.de/~michael/fe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sendmail"
+
+DEPEND="sys-libs/ncurses
+ sendmail? ( virtual/mta )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.8-makefile.patch"
+}
+
+src_configure() {
+ econf $(use_enable sendmail)
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ datadir="${D}"/usr/share \
+ MANDIR="${D}"/usr/share/man \
+ install
+
+ dodoc NEWS README
+ dohtml fe.html
+}
diff --git a/app-editors/ne/ChangeLog b/app-editors/ne/ChangeLog
index 3a6ecbeccef6..e6a0c01b516c 100644
--- a/app-editors/ne/ChangeLog
+++ b/app-editors/ne/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ne
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.43 2011/03/12 13:37:40 swegener Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.44 2012/03/16 10:18:42 patrick Exp $
+
+*ne-2.3 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +ne-2.3.ebuild:
+ Bump
12 Mar 2011; Sven Wegener <swegener@gentoo.org> -ne-1.42.ebuild,
-ne-1.43.ebuild:
diff --git a/app-editors/ne/ne-2.3.ebuild b/app-editors/ne/ne-2.3.ebuild
new file mode 100644
index 000000000000..1daa42a82176
--- /dev/null
+++ b/app-editors/ne/ne-2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.3.ebuild,v 1.1 2012/03/16 10:18:42 patrick Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="http://ne.dsi.unimi.it/"
+SRC_URI="http://ne.dsi.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ sed -i -e 's/-O3//' src/makefile || die
+ epatch "${FILESDIR}"/${PN}-2.1-asneeded.patch
+}
+
+src_compile() {
+ emake \
+ -j1 \
+ -C src \
+ ne \
+ OPTS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/ne" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin src/ne || die "dobin failed"
+
+ insinto /usr/share/ne/syntax
+ doins syntax/*.jsf || die "doins failed"
+
+ doman doc/ne.1 || die "doman failed"
+ dohtml -r doc/html/. || die "dohtml failed"
+ dodoc CHANGES README doc/*.{txt,pdf,texinfo} doc/default.* || die "dodoc failed"
+}
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 5aa1578fbc39..f4a19972d48e 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.51 2012/01/21 22:08:26 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.52 2012/03/16 10:23:30 patrick Exp $
+
+*tea-32.0.0 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +tea-32.0.0.ebuild:
+ Bump
*tea-31.2.0 (21 Jan 2012)
diff --git a/app-editors/tea/tea-32.0.0.ebuild b/app-editors/tea/tea-32.0.0.ebuild
new file mode 100644
index 000000000000..0b327089d8b9
--- /dev/null
+++ b/app-editors/tea/tea-32.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.0.ebuild,v 1.1 2012/03/16 10:23:30 patrick Exp $
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+RDEPEND="sys-libs/zlib
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )"
+DEPEND="${RDEPEND}
+ hunspell? ( dev-util/pkgconfig )"
+
+src_configure() {
+ local myopts
+ if use aspell ; then
+ myopts="USE_ASPELL=true"
+ else
+ myopts="USE_ASPELL=false"
+ fi
+
+ if use hunspell ; then
+ myopts="${myopts} USE_HUNSPELL=true"
+ else
+ myopts="${myopts} USE_HUNSPELL=false"
+ fi
+
+ eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
+}
+
+src_install() {
+ dobin bin/tea
+ dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
+ doicon icons/tea_icon_v2.png
+
+ make_desktop_entry tea Tea tea_icon_v2 Utility
+}