summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2006-05-28 04:53:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2006-05-28 04:53:51 +0000
commite4d30f50da0bfd2a7754211497641f035f6fb855 (patch)
tree55304e9aeece99ea6d14dbe607ad6e93fd726b00 /app-editors/vim/vim-7.0.17.ebuild
parentRefix bug #120403 with permission from robbat2 (diff)
downloadhistorical-e4d30f50da0bfd2a7754211497641f035f6fb855.tar.gz
historical-e4d30f50da0bfd2a7754211497641f035f6fb855.tar.bz2
historical-e4d30f50da0bfd2a7754211497641f035f6fb855.zip
version bump to 7.0.17 and vimtutor fix
Package-Manager: portage-2.1_rc1-r2
Diffstat (limited to 'app-editors/vim/vim-7.0.17.ebuild')
-rw-r--r--app-editors/vim/vim-7.0.17.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.0.17.ebuild b/app-editors/vim/vim-7.0.17.ebuild
new file mode 100644
index 000000000000..84a93e77d4d9
--- /dev/null
+++ b/app-editors/vim/vim-7.0.17.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0.17.ebuild,v 1.1 2006/05/28 04:52:54 rphillips Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND} !app-editors/nvi
+ !minimal? ( ~app-editors/vim-core-${PV} )"