summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-11-10 10:53:24 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-11-10 10:53:24 +0000
commit0098ffe709a1a715d2c72f62dbf04cce6e2951f4 (patch)
treea5a3260808226ba4b2a4eeb1f586f26b6c6ac6e1 /app-editors/scite/scite-1.74.ebuild
parentremoving =dev-lang/php-5.2.5 mask again, tarball is on our mirrors (diff)
downloadhistorical-0098ffe709a1a715d2c72f62dbf04cce6e2951f4.tar.gz
historical-0098ffe709a1a715d2c72f62dbf04cce6e2951f4.tar.bz2
historical-0098ffe709a1a715d2c72f62dbf04cce6e2951f4.zip
Fix quoting in 1.74, remove obsolete 1.73.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'app-editors/scite/scite-1.74.ebuild')
-rw-r--r--app-editors/scite/scite-1.74.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-editors/scite/scite-1.74.ebuild b/app-editors/scite/scite-1.74.ebuild
index a3b882c86cce..4a52c3569a66 100644
--- a/app-editors/scite/scite-1.74.ebuild
+++ b/app-editors/scite/scite-1.74.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.74.ebuild,v 1.1 2007/06/25 21:21:16 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.74.ebuild,v 1.2 2007/11/10 10:53:23 nelchael Exp $
inherit toolchain-funcs eutils
@@ -20,18 +20,18 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
>=sys-apps/sed-4"
-S=${WORKDIR}/${PN}/gtk
+S="${WORKDIR}/${PN}/gtk"
src_unpack() {
unpack ${A}
- cd ${WORKDIR}/scintilla/gtk
+ cd "${WORKDIR}/scintilla/gtk"
sed -i makefile \
-e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
-e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
-e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
|| die "error patching makefile"
- cd ${S}
+ cd "${S}"
sed -i makefile \
-e 's#usr/local#usr#g' \
-e 's#/gnome/apps/Applications#/applications#' \
@@ -41,7 +41,7 @@ src_unpack() {
-e 's#${D}##' \
-e 's#-g root#-g 0#' \
|| die "error patching makefile"
- epatch ${FILESDIR}/${P}-install.patch
+ epatch "${FILESDIR}/${P}-install.patch"
}
src_compile() {
@@ -57,16 +57,16 @@ src_install() {
dodir /usr/bin
dodir /usr/share/{pixmaps,applications}
- make prefix=${D}/usr install || die
+ make prefix="${D}/usr" install || die
# we have to keep this because otherwise it'll break upgrading
- mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
dosym /usr/bin/scite /usr/bin/SciTE
# replace .desktop file with our own working version
insinto /usr/share/applications
- rm -f ${D}/usr/share/applications/SciTE.desktop
- doins ${FILESDIR}/scite.desktop
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
doman ../doc/scite.1
dodoc ../README