summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-20 11:45:33 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-20 11:45:33 +0000
commitb96392543a49539807146301632031b1abb447fc (patch)
tree035bb3be97294603e4f50e8925dcd3b553214e9e /app-editors/qemacs
parentVersion bumped. This closes bug #78999. (diff)
downloadhistorical-b96392543a49539807146301632031b1abb447fc.tar.gz
historical-b96392543a49539807146301632031b1abb447fc.tar.bz2
historical-b96392543a49539807146301632031b1abb447fc.zip
Added a patch to enable users to choose whether to create ~ backup file. This closes bug #75052.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-editors/qemacs')
-rw-r--r--app-editors/qemacs/ChangeLog9
-rw-r--r--app-editors/qemacs/Manifest7
-rw-r--r--app-editors/qemacs/files/digest-qemacs-0.3.1-r11
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-make_backup.patch69
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r1.ebuild42
5 files changed, 125 insertions, 3 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 056fe7b5dcce..232ac6dc39b7 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.11 2005/01/01 13:33:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.12 2005/02/20 11:45:33 usata Exp $
+
+*qemacs-0.3.1-r1 (20 Feb 2005)
+
+ 20 Feb 2005; Mamoru KOMACHI <usata@gentoo.org>
+ +files/qemacs-0.3.1-make_backup.patch, +qemacs-0.3.1-r1.ebuild:
+ Added a patch to enable users to choose whether to create ~ backup file.
+ This closes bug #75052.
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
qemacs-0.3.1.ebuild:
diff --git a/app-editors/qemacs/Manifest b/app-editors/qemacs/Manifest
index c20f1a468204..2d4c461b570a 100644
--- a/app-editors/qemacs/Manifest
+++ b/app-editors/qemacs/Manifest
@@ -1,6 +1,9 @@
-MD5 3a801a08e0c9e8f676ae95c583eb2288 ChangeLog 1496
+MD5 810779eeb2b3a566e6945288ce47fa67 ChangeLog 1740
+MD5 664f41fd92c3f0c4e137748b1a80727d qemacs-0.3.1-r1.ebuild 1150
MD5 b0456a6f9ce7c4da0ffaaa00c11c8826 qemacs-0.3.1.ebuild 1116
+MD5 a4c613ab493b62325669d8d1353c8b2e files/qemacs-Makefile-gentoo.patch 421
MD5 1bef560680eaab10f0524f228c5dc6eb files/digest-qemacs-0.3.1 64
MD5 26f2791358b330724fe8dfa7a4dba22a files/qemacs-0.3.1-configure-gentoo.patch 496
-MD5 a4c613ab493b62325669d8d1353c8b2e files/qemacs-Makefile-gentoo.patch 421
MD5 e7a9a6e25a384848c2b87891e7e7c973 files/qemacs-0.3.1-tty_utf8.patch 952
+MD5 635697c90ee6f2498f3f566a0932f2c2 files/qemacs-0.3.1-make_backup.patch 2141
+MD5 1bef560680eaab10f0524f228c5dc6eb files/digest-qemacs-0.3.1-r1 64
diff --git a/app-editors/qemacs/files/digest-qemacs-0.3.1-r1 b/app-editors/qemacs/files/digest-qemacs-0.3.1-r1
new file mode 100644
index 000000000000..86ccf24a3138
--- /dev/null
+++ b/app-editors/qemacs/files/digest-qemacs-0.3.1-r1
@@ -0,0 +1 @@
+MD5 74d85dee9861d494bf1f9c53bbc85298 qemacs-0.3.1.tar.gz 809124
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-make_backup.patch b/app-editors/qemacs/files/qemacs-0.3.1-make_backup.patch
new file mode 100644
index 000000000000..c8839bff58a2
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.1-make_backup.patch
@@ -0,0 +1,69 @@
+diff -ruN qemacs-0.3.1/buffer.c qemacs-0.3.1-aon1/buffer.c
+--- qemacs-0.3.1/buffer.c 2003-04-22 01:01:42.000000000 +0300
++++ qemacs-0.3.1-aon1/buffer.c 2004-11-12 18:53:18.510488192 +0200
+@@ -1437,11 +1437,12 @@
+ if (stat(filename, &st) == 0)
+ mode = st.st_mode & 0777;
+
+- /* backup old file if present */
+- strcpy(buf1, filename);
+- strcat(buf1, "~");
+- rename(filename, buf1);
+-
++ /* backup old file if present and make-backup-files is on */
++ if(mbf == 1) {
++ strcpy(buf1, filename);
++ strcat(buf1, "~");
++ rename(filename, buf1);
++ }
+ ret = b->data_type->buffer_save(b, filename);
+ if (ret < 0)
+ return ret;
+diff -ruN qemacs-0.3.1/qe.c qemacs-0.3.1-aon1/qe.c
+--- qemacs-0.3.1/qe.c 2003-04-22 01:01:42.000000000 +0300
++++ qemacs-0.3.1-aon1/qe.c 2004-11-12 18:53:52.524317304 +0200
+@@ -61,7 +61,7 @@
+ static QEditScreen global_screen;
+ static int screen_width = 0;
+ static int screen_height = 0;
+-
++mbf = 1;
+ /* mode handling */
+
+ void qe_register_mode(ModeDef *m)
+@@ -4319,6 +4319,14 @@
+ do_refresh(qs->first_window);
+ }
+
++static void make_backup_files(EditState *s) {
++ if(mbf == 1) {
++ mbf = 0;
++ } else {
++ mbf = 1;
++ }
++}
++
+ /* compute default path for find/save buffer */
+ static void get_default_path(EditState *s, char *buf, int buf_size)
+ {
+diff -ruN qemacs-0.3.1/qe.h qemacs-0.3.1-aon1/qe.h
+--- qemacs-0.3.1/qe.h 2003-04-22 01:01:42.000000000 +0300
++++ qemacs-0.3.1-aon1/qe.h 2004-11-12 18:53:18.516487280 +0200
+@@ -1140,3 +1140,5 @@
+ int qe_bitmap_format_to_pix_fmt(int format);
+
+ #endif
++
++int mbf;
+diff -ruN qemacs-0.3.1/qeconfig.h qemacs-0.3.1-aon1/qeconfig.h
+--- qemacs-0.3.1/qeconfig.h 2003-04-22 01:01:42.000000000 +0300
++++ qemacs-0.3.1-aon1/qeconfig.h 2004-11-12 18:53:18.516487280 +0200
+@@ -68,5 +68,7 @@
+ CMD1( KEY_CTRLX(KEY_CTRL('u')), KEY_NONE, "upcase-region",
+ do_changecase_region, 1)
+
++ CMD0( KEY_NONE, KEY_NONE, "make-backup-files", make_backup_files)
++
+ /* keyboard macros */
+ CMD0( KEY_CTRLX('('), KEY_NONE, "start-kbd-macro", do_start_macro)
+ CMD0( KEY_CTRLX(')'), KEY_NONE, "end-kbd-macro", do_end_macro)
diff --git a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..1a3da3a8c127
--- /dev/null
+++ b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.1 2005/02/20 11:45:33 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor."
+HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
+SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="X png unicode"
+
+DEPEND="X? ( virtual/x11 )
+ png? ( =media-libs/libpng-1.2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
+ epatch ${FILESDIR}/${P}-configure-gentoo.patch
+ epatch ${FILESDIR}/${P}-make_backup.patch
+ use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
+}
+
+src_compile() {
+ local myconf
+ use X && myconf="--enable-x11" || myconf="--disable-x11"
+ use png && myconf="${myconf} --enable-png" || myconf="${myconf} --disable-png"
+ econf ${myconf} || die "econf failed"
+ emake -j1 || die
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall || die
+ doman qe.1
+ dodoc Changelog README TODO VERSION
+ dohtml *.html
+}