summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-03-29 19:37:16 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-03-29 19:37:16 +0000
commitfa52e063a2893e927b10bb886fa2cedb31ae5e5e (patch)
tree949ff383fa83ccff93afecd5f25fa61262086e1a /app-editors/leafpad/leafpad-0.8.14.ebuild
parent(#214653) Fix build by using correct driver-patch version. (diff)
downloadhistorical-fa52e063a2893e927b10bb886fa2cedb31ae5e5e.tar.gz
historical-fa52e063a2893e927b10bb886fa2cedb31ae5e5e.tar.bz2
historical-fa52e063a2893e927b10bb886fa2cedb31ae5e5e.zip
version bump from upstream
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-editors/leafpad/leafpad-0.8.14.ebuild')
-rw-r--r--app-editors/leafpad/leafpad-0.8.14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/leafpad/leafpad-0.8.14.ebuild b/app-editors/leafpad/leafpad-0.8.14.ebuild
new file mode 100644
index 000000000000..f2cfacf7c488
--- /dev/null
+++ b/app-editors/leafpad/leafpad-0.8.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leafpad/leafpad-0.8.14.ebuild,v 1.1 2008/03/29 19:37:16 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple GTK+ Text Editor"
+HOMEPAGE="http://tarot.freeshell.org/leafpad/"
+SRC_URI="http://savannah.nongnu.org/download/leafpad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="emacs"
+
+RDEPEND=">=x11-libs/gtk+-2.10"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+ econf --enable-chooser --enable-print $(use_enable emacs)
+ emake
+}
+
+src_install() {
+ einstall
+ dodoc AUTHORS ChangeLog NEWS README
+}