summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-12-27 18:55:23 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-12-27 18:55:23 +0000
commit02e8302c211e8c706f43a4f7dc86508040e9ab9f (patch)
treea7c4db0cd12f8780e0da0208b8479ef6b94b06fc /app-editors/jedit
parentremove xmms-1.2.7-link-libstdc++.patch from being applied (diff)
downloadhistorical-02e8302c211e8c706f43a4f7dc86508040e9ab9f.tar.gz
historical-02e8302c211e8c706f43a4f7dc86508040e9ab9f.tar.bz2
historical-02e8302c211e8c706f43a4f7dc86508040e9ab9f.zip
new version
Diffstat (limited to 'app-editors/jedit')
-rw-r--r--app-editors/jedit/ChangeLog6
-rw-r--r--app-editors/jedit/files/digest-jedit-4.1_pre71
-rw-r--r--app-editors/jedit/jedit-4.1_pre7.ebuild68
3 files changed, 74 insertions, 1 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index c8fcc8f170da..3a403e044d0a 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/jedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.13 2002/11/26 18:05:07 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.14 2002/12/27 18:55:23 blizzy Exp $
+
+*jedit-4.1_pre7 (27 Dec 2002)
+
+ 27 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
26 Nov 2002; Maik Schreiber <blizzy@gentoo.org> jedit-4.1_pre4.ebuild:
Removed "~ppc ~sparc ~sparc64 ~alpha" from KEYWORDS. It seems there never
diff --git a/app-editors/jedit/files/digest-jedit-4.1_pre7 b/app-editors/jedit/files/digest-jedit-4.1_pre7
new file mode 100644
index 000000000000..e2bdd220cafc
--- /dev/null
+++ b/app-editors/jedit/files/digest-jedit-4.1_pre7
@@ -0,0 +1 @@
+MD5 b54335629aa76f1472d8ba089789ef00 jedit41pre7source.tar.gz 1094153
diff --git a/app-editors/jedit/jedit-4.1_pre7.ebuild b/app-editors/jedit/jedit-4.1_pre7.ebuild
new file mode 100644
index 000000000000..a239fe9baffd
--- /dev/null
+++ b/app-editors/jedit/jedit-4.1_pre7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.1_pre7.ebuild,v 1.1 2002/12/27 18:55:23 blizzy Exp $
+
+MY_PV="41pre7"
+
+DESCRIPTION="Programmer's editor written in Java"
+HOMEPAGE="http://www.jedit.org"
+SRC_URI="mirror://sourceforge/jedit/jedit${MY_PV}source.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="jikes"
+
+RDEPEND=">=virtual/jdk-1.3"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+S="${WORKDIR}/jEdit"
+
+src_compile() {
+ local antflags
+
+ antflags=""
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/share/jedit
+ dodir /usr/bin
+
+ cp -R jedit.jar jars doc macros modes properties startup ${D}/usr/share/jedit
+ cd ${D}/usr/share/jedit
+ chmod -R u+rw,ug-s,go+u,go-w \
+ jedit.jar jars doc macros modes properties startup
+
+ cat >${D}/usr/share/jedit/jedit.sh <<-EOF
+ #!/bin/bash
+
+ java -jar /usr/share/jedit/jedit.jar $@
+ EOF
+ chmod 755 ${D}/usr/share/jedit/jedit.sh
+
+ ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+}
+
+pkg_postinst() {
+ touch /usr/share/jedit/jars/.keep
+
+ einfo "The system directory for jEdit plugins is"
+ einfo "/usr/share/jedit/jars"
+}
+
+pkg_postrm() {
+ einfo "jEdit plugins installed into /usr/share/jedit/jars"
+ einfo "(after installation of jEdit itself) haven't been"
+ einfo "removed. To get rid of jEdit completely, you may"
+ einfo "want to run"
+ einfo ""
+ einfo "\trm -r /usr/share/jedit"
+}