summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2002-12-14 21:14:04 +0000
committerHanno Boeck <hanno@gentoo.org>2002-12-14 21:14:04 +0000
commit7c6e4f3c1635d878dd2d0630aa7cd4ecd573fa7b (patch)
tree09e690a82cd23de6e0fad45bbe1d7a2348ce15da /app-editors/bluefish/bluefish-0.8.ebuild
parentmasked omniORB-4.0.0 and omniORBpy (gcc-3.2 bug?) (diff)
downloadhistorical-7c6e4f3c1635d878dd2d0630aa7cd4ecd573fa7b.tar.gz
historical-7c6e4f3c1635d878dd2d0630aa7cd4ecd573fa7b.tar.bz2
historical-7c6e4f3c1635d878dd2d0630aa7cd4ecd573fa7b.zip
bluefish 0.8 ebuild, old gtk2-snapshots removed
Diffstat (limited to 'app-editors/bluefish/bluefish-0.8.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-0.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-0.8.ebuild b/app-editors/bluefish/bluefish-0.8.ebuild
new file mode 100644
index 000000000000..1bb808f31b19
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.8.ebuild,v 1.1 2002/12/14 21:14:04 hanno Exp $
+
+MY_P=${PN}-gtk2-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${MY_P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+IUSE="nls perl"
+
+DEPEND=">=x11-libs/gtk+-2.0.5
+ >=media-libs/freetype-2.0.9
+ >=media-libs/gdk-pixbuf-0.18
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--with-autocomplet"
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+
+ emake || die
+
+}
+
+src_install() {
+ einstall \
+ datadir=${D}/usr/share \
+ pkgdatadir=${D}/usr/share/bluefish
+}