summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-05-15 17:11:44 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-05-15 17:11:44 +0000
commit59b07c2e1309bb4d468b6608dbdeee628f21ae0b (patch)
tree3a05f9666b6fbff31df0aa377a3fa93b4327c346 /app-doc
parentmissing stuff (mirroring doc) (diff)
downloadhistorical-59b07c2e1309bb4d468b6608dbdeee628f21ae0b.tar.gz
historical-59b07c2e1309bb4d468b6608dbdeee628f21ae0b.tar.bz2
historical-59b07c2e1309bb4d468b6608dbdeee628f21ae0b.zip
added support for GENTOO_SRCDIR
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gentoo-web/gentoo-web-2.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-doc/gentoo-web/gentoo-web-2.2.ebuild b/app-doc/gentoo-web/gentoo-web-2.2.ebuild
index 3d085b9c188f..0faf5b1098cc 100644
--- a/app-doc/gentoo-web/gentoo-web-2.2.ebuild
+++ b/app-doc/gentoo-web/gentoo-web-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.2.ebuild,v 1.53 2002/05/15 17:09:29 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.2.ebuild,v 1.54 2002/05/15 17:11:44 drobbins Exp $
# WARNING: THIS EBUILD SHOULD BE EDITED BY DANIEL ROBBINS ONLY
@@ -27,8 +27,11 @@ src_unpack() {
ln -s /home/drobbins/gentoo-src gentoo-src
elif [ "$myhost" = "chiba.3jane.net" ]
cvs -d /home/cvsroot co gentoo-src
+ elif [ -n "$GENTOO_SRCDIR" ]
+ then
+ ln -s ${GENTOO_SRCDIR} gentoo-src || die
else
- die "This ebuild has not been tweaked for your system."
+ die "Please set the GENTOO_SRCDIR env var to point to the gentoo-src tree"
fi
}