summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-07 11:16:54 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-07 11:16:54 +0000
commitdf57d100ec583f0e7f647f3ed3efae13db351acd (patch)
tree3f7434c2200f1b1c20ffab9b6cf5f384fe9b30e2 /app-dicts
parentVersion bump. (diff)
downloadhistorical-df57d100ec583f0e7f647f3ed3efae13db351acd.tar.gz
historical-df57d100ec583f0e7f647f3ed3efae13db351acd.tar.bz2
historical-df57d100ec583f0e7f647f3ed3efae13db351acd.zip
Version bump.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/libydpdict/ChangeLog8
-rw-r--r--app-dicts/libydpdict/libydpdict-1.0.0.ebuild20
-rw-r--r--app-dicts/ydpdict/ChangeLog7
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.0.ebuild44
4 files changed, 77 insertions, 2 deletions
diff --git a/app-dicts/libydpdict/ChangeLog b/app-dicts/libydpdict/ChangeLog
index 6c8c6e218c6c..a695be3cc1ad 100644
--- a/app-dicts/libydpdict/ChangeLog
+++ b/app-dicts/libydpdict/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/libydpdict
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/libydpdict/ChangeLog,v 1.3 2008/08/27 22:41:25 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/libydpdict/ChangeLog,v 1.4 2008/09/07 11:15:22 spock Exp $
+
+*libydpdict-1.0.0 (07 Sep 2008)
+
+ 07 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ +libydpdict-1.0.0.ebuild:
+ Version bump.
27 Aug 2008; Dawid Węgliński <cla@gentoo.org> libydpdict-0.99.3.ebuild:
Stable on x86/amd64 (bug #209813)
diff --git a/app-dicts/libydpdict/libydpdict-1.0.0.ebuild b/app-dicts/libydpdict/libydpdict-1.0.0.ebuild
new file mode 100644
index 000000000000..32eb6b65af1d
--- /dev/null
+++ b/app-dicts/libydpdict/libydpdict-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/libydpdict/libydpdict-1.0.0.ebuild,v 1.1 2008/09/07 11:15:22 spock Exp $
+
+DESCRIPTION="Library for handling the Collins Dictionary database."
+HOMEPAGE="http://toxygen.net/ydpdict/"
+SRC_URI="http://toxygen.net/ydpdict/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
+}
diff --git a/app-dicts/ydpdict/ChangeLog b/app-dicts/ydpdict/ChangeLog
index 157884ad341c..64fe4822ebd9 100644
--- a/app-dicts/ydpdict/ChangeLog
+++ b/app-dicts/ydpdict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/ydpdict
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/ydpdict/ChangeLog,v 1.11 2008/08/27 22:43:50 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ydpdict/ChangeLog,v 1.12 2008/09/07 11:16:54 spock Exp $
+
+*ydpdict-1.0.0 (07 Sep 2008)
+
+ 07 Sep 2008; Michał Januszewski <spock@gentoo.org> +ydpdict-1.0.0.ebuild:
+ Version bump.
27 Aug 2008; Dawid Węgliński <cla@gentoo.org> ydpdict-0.99.3.ebuild:
Stable on x86/amd64 (bug #209813)
diff --git a/app-dicts/ydpdict/ydpdict-1.0.0.ebuild b/app-dicts/ydpdict/ydpdict-1.0.0.ebuild
new file mode 100644
index 000000000000..48956e4b7297
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ydpdict/ydpdict-1.0.0.ebuild,v 1.1 2008/09/07 11:16:54 spock Exp $
+
+DESCRIPTION="Interface for the Collins Dictionary."
+HOMEPAGE="http://toxygen.net/ydpdict/"
+SRC_URI="http://toxygen.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ao"
+
+RDEPEND="=app-dicts/libydpdict-${PV}*
+ ao? ( media-libs/libao )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+src_compile() {
+ econf \
+ $(use_with ao libao) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir "/etc"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}