summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-14 14:41:30 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-14 14:41:30 +0000
commita6deaf676cd979b8405a50cd7236665299a8da3b (patch)
tree5256eff1c21d238344da961c4235af665d9f539b /app-crypt/ophcrack/ophcrack-3.3.0.ebuild
parentStable for sparc, wrt bug #506786 (diff)
downloadhistorical-a6deaf676cd979b8405a50cd7236665299a8da3b.tar.gz
historical-a6deaf676cd979b8405a50cd7236665299a8da3b.tar.bz2
historical-a6deaf676cd979b8405a50cd7236665299a8da3b.zip
[QA] EAPI 1 -> 5. Added missing dev-qt/qtcore:4 dependency.
Package-Manager: portage-HEAD/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.3.0.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.3.0.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.3.0.ebuild b/app-crypt/ophcrack/ophcrack-3.3.0.ebuild
index 70d9b0d45a7d..6f20a16200ae 100644
--- a/app-crypt/ophcrack/ophcrack-3.3.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.3.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.3.0.ebuild,v 1.4 2013/03/02 19:14:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.3.0.ebuild,v 1.5 2014/05/14 14:41:26 tomwij Exp $
-EAPI="1"
+EAPI="5"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -16,27 +16,20 @@ IUSE="qt4 debug"
CDEPEND="dev-libs/openssl
net-libs/netwib
- qt4? ( dev-qt/qtgui:4 )"
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )"
DEPEND="app-arch/unzip
virtual/pkgconfig
${CDEPEND}"
RDEPEND="app-crypt/ophcrack-tables
${CDEPEND}"
-src_compile() {
- local myconf
-
- myconf="$(use_enable qt4 gui)"
- myconf="${myconf} $(use_enable debug)"
-
- econf ${myconf} || die "Failed to compile"
- emake || die "Failed to make"
+src_configure() {
+ econf $(use_enable qt4 gui) $(use_enable debug)
}
src_install() {
- emake install DESTDIR="${D}" || die "Installation failed."
+ default
- cd "${S}"
- newicon src/gui/pixmaps/os.xpm ophcrack.xpm
- make_desktop_entry "${PN}" OphCrack ophcrack
+ newicon src/gui/pixmaps/os.xpm ${PN}.xpm
+ make_desktop_entry "${PN}" OphCrack ${PN}
}