summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-10-29 05:31:21 +0000
committerJeroen Roovers <jer@gentoo.org>2008-10-29 05:31:21 +0000
commit2449306829e1a52e3689a04e975ce1cfc3336fe1 (patch)
treedc4e3a29dd885831fb221e3314d55da4f4e6c39c /app-benchmarks/nbench/nbench-2.2.3.ebuild
parentMarked ~hppa too. (diff)
downloadhistorical-2449306829e1a52e3689a04e975ce1cfc3336fe1.tar.gz
historical-2449306829e1a52e3689a04e975ce1cfc3336fe1.tar.bz2
historical-2449306829e1a52e3689a04e975ce1cfc3336fe1.zip
Pick up maintainership. Version bump. Patch Makefile to use toolchain CC (bug #243520).
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.25-gentoo-r7-JeR i686
Diffstat (limited to 'app-benchmarks/nbench/nbench-2.2.3.ebuild')
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-benchmarks/nbench/nbench-2.2.3.ebuild b/app-benchmarks/nbench/nbench-2.2.3.ebuild
new file mode 100644
index 000000000000..04798594ae55
--- /dev/null
+++ b/app-benchmarks/nbench/nbench-2.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/nbench/nbench-2.2.3.ebuild,v 1.1 2008/10/29 05:31:20 jer Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-byte-${PV}"
+DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
+HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
+SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ sed -i -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' sysinfo.sh || die
+ sed -i -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' nbench1.h || die
+
+ make LINKFLAGS="${LDFLAGS}" CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin nbench
+ insinto /usr/share/nbench
+ doins NNET.DAT
+
+ dodoc Changes README* RESULT bdoc.txt
+}