summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-10 03:09:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-10 03:09:16 +0000
commit82ce04c96bdfc04d067834e48ad9f121f9bc7c05 (patch)
tree34f699e02413246e7c4b647d589ed99af73b6f52 /app-arch
parentstable on alpha (diff)
downloadhistorical-82ce04c96bdfc04d067834e48ad9f121f9bc7c05.tar.gz
historical-82ce04c96bdfc04d067834e48ad9f121f9bc7c05.tar.bz2
historical-82ce04c96bdfc04d067834e48ad9f121f9bc7c05.zip
Add patch by Peter Beutner to fix handling of symlinks #80246 by Yuri Karaban.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cpio/ChangeLog8
-rw-r--r--app-arch/cpio/Manifest13
-rw-r--r--app-arch/cpio/cpio-2.6-r2.ebuild41
-rw-r--r--app-arch/cpio/files/2.6-lstat.patch28
-rw-r--r--app-arch/cpio/files/digest-cpio-2.6-r21
5 files changed, 84 insertions, 7 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 83e5603907c0..7fa468998bff 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/cpio
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.17 2005/02/06 19:38:07 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.18 2005/02/10 03:09:16 vapier Exp $
+
+*cpio-2.6-r2 (09 Feb 2005)
+
+ 09 Feb 2005; Mike Frysinger <vapier@gentoo.org> +files/2.6-lstat.patch,
+ +cpio-2.6-r2.ebuild:
+ Add patch by Peter Beutner to fix handling of symlinks #80246 by Yuri Karaban.
06 Feb 2005; Joshua Kinard <kumba@gentoo.org> cpio-2.6-r1.ebuild:
Marked stable on mips.
diff --git a/app-arch/cpio/Manifest b/app-arch/cpio/Manifest
index 003d408ad23c..82279fac42f4 100644
--- a/app-arch/cpio/Manifest
+++ b/app-arch/cpio/Manifest
@@ -1,9 +1,10 @@
-MD5 776401ceeccb5447210996d318fe1c75 ChangeLog 4324
-MD5 ca553fdcf418df4fac0aa9000c76b9d1 cpio-2.5.ebuild 797
-MD5 f718f5b052e39ae846008ffa59e646b4 cpio-2.6-r1.ebuild 1011
+MD5 5cb8d7322c3496062556b0279b21f315 ChangeLog 4532
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 527f6d401d12741d17a7ac7761a6d2d7 files/2.6-isnumber.patch 861
-MD5 7894f923500cbeeb0b36117e08049b5d files/2.6-rili-big-files.patch 2709
+MD5 6f13024f2d96729f04bf34aceee831b3 cpio-2.6-r1.ebuild 1011
+MD5 b302bb9e913d5ba1e931a23168b4c9fd cpio-2.6-r2.ebuild 1079
MD5 e5b0619beac9b1fe4490c3424e903f1f files/2.6-umask.patch 1382
-MD5 a0838e9d5ff0463ecb8758db81652ff1 files/digest-cpio-2.5 60
+MD5 ae93625090241de60fb662d4dd0153dc files/2.6-lstat.patch 843
+MD5 527f6d401d12741d17a7ac7761a6d2d7 files/2.6-isnumber.patch 861
MD5 898f15e2e1a554916e69e9397f130e81 files/digest-cpio-2.6-r1 61
+MD5 898f15e2e1a554916e69e9397f130e81 files/digest-cpio-2.6-r2 61
+MD5 7894f923500cbeeb0b36117e08049b5d files/2.6-rili-big-files.patch 2709
diff --git a/app-arch/cpio/cpio-2.6-r2.ebuild b/app-arch/cpio/cpio-2.6-r2.ebuild
new file mode 100644
index 000000000000..3e9812c26566
--- /dev/null
+++ b/app-arch/cpio/cpio-2.6-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r2.ebuild,v 1.1 2005/02/10 03:09:16 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A file archival tool which can also read and write tar files"
+HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
+SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-rili-big-files.patch #68520
+ epatch "${FILESDIR}"/${PV}-isnumber.patch #74929
+ epatch "${FILESDIR}"/${PV}-umask.patch #79844
+ epatch "${FILESDIR}"/${PV}-lstat.patch #80246
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --bindir=/bin \
+ --with-rmt=/usr/sbin/rmt \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README INSTALL
+ rm -f "${D}"/usr/share/man/man1/mt.1
+ rmdir "${D}"/usr/libexec
+}
diff --git a/app-arch/cpio/files/2.6-lstat.patch b/app-arch/cpio/files/2.6-lstat.patch
new file mode 100644
index 000000000000..e9478d6af357
--- /dev/null
+++ b/app-arch/cpio/files/2.6-lstat.patch
@@ -0,0 +1,28 @@
+cpio is acting as if always invoked with -L (copy the file that a symlink
+points to, rather the symlink itself)
+reason: missing check for lstat function in configure script
+see: http://lists.gnu.org/archive/html/bug-cpio/2005-01/msg00003.html
+ http://bugs.gentoo.org/show_bug.cgi?id=80246
+
+--- cpio-2.6-orig/config.h.in
++++ cpio-2.6/config.h.in
+@@ -310,6 +310,9 @@
+ /* Define to 1 if you have the <unistd.h> header file. */
+ #undef HAVE_UNISTD_H
+
++/* Define to 1 if you have the `lstat' function. */
++#undef HAVE_LSTAT
++
+ /* Define to 1 if you have the <utime.h> header file. */
+ #undef HAVE_UTIME_H
+
+--- cpio-2.6-orig/configure
++++ cpio-2.6/configure
+@@ -1321,6 +1321,7 @@
+ gl_func_list="$gl_func_list iswprint"
+ gl_func_list="$gl_func_list mbsinit"
+ gl_header_list="$gl_header_list unistd.h"
++gl_func_list="$gl_func_list lstat"
+
+
+
diff --git a/app-arch/cpio/files/digest-cpio-2.6-r2 b/app-arch/cpio/files/digest-cpio-2.6-r2
new file mode 100644
index 000000000000..822d7f4e46f3
--- /dev/null
+++ b/app-arch/cpio/files/digest-cpio-2.6-r2
@@ -0,0 +1 @@
+MD5 25e0e8725bc60ed3460c9cde92752674 cpio-2.6.tar.bz2 448452