summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-20 23:09:40 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-20 23:09:40 +0000
commitc045469542f7ee5d0656afc3123fd6c0517ab9e8 (patch)
tree1d93256225bff1c20c4e36a9f0ade3e28ee83431 /app-arch/gzip
parentSome more build fixes. (diff)
downloadhistorical-c045469542f7ee5d0656afc3123fd6c0517ab9e8.tar.gz
historical-c045469542f7ee5d0656afc3123fd6c0517ab9e8.tar.bz2
historical-c045469542f7ee5d0656afc3123fd6c0517ab9e8.zip
rename patch
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/ChangeLog6
-rw-r--r--app-arch/gzip/files/gzip-1.3.5-CVE-2006-4334-8.patch182
-rw-r--r--app-arch/gzip/gzip-1.3.5-r9.ebuild4
3 files changed, 187 insertions, 5 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index d75ff2213ff1..aee4398c087f 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-arch/gzip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.62 2006/09/20 17:58:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.63 2006/09/20 23:09:40 vapier Exp $
20 Sep 2006; Markus Rothe <corsair@gentoo.org> gzip-1.3.5-r9.ebuild:
Stable on ppc64; bug #145511
@@ -14,8 +14,8 @@
*gzip-1.3.5-r9 (20 Sep 2006)
20 Sep 2006; Christian Hartmann <ian@gentoo.org>
- +files/CVE-2006-4334-8.diff, +gzip-1.3.5-r9.ebuild:
- Revbump for bug #145511 - commit approved by DerCorny
+ +files/gzip-1.3.5-CVE-2006-4334-8.patch, +gzip-1.3.5-r9.ebuild:
+ Revbump for bug #145511 - commit approved by DerCorny.
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-gzip-1.3.5-r8,
Manifest:
diff --git a/app-arch/gzip/files/gzip-1.3.5-CVE-2006-4334-8.patch b/app-arch/gzip/files/gzip-1.3.5-CVE-2006-4334-8.patch
new file mode 100644
index 000000000000..85c618741294
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.3.5-CVE-2006-4334-8.patch
@@ -0,0 +1,182 @@
+http://bugs.gentoo.org/145511
+
+--- gzip-1.3.5/gzip.h
++++ gzip-1.3.5/gzip.h
+@@ -198,6 +198,8 @@
+ extern int to_stdout; /* output to stdout (-c) */
+ extern int save_orig_name; /* set if original name must be saved */
+
++#define MIN(a,b) ((a) <= (b) ? (a) : (b))
++
+ #define get_byte() (inptr < insize ? inbuf[inptr++] : fill_inbuf(0))
+ #define try_byte() (inptr < insize ? inbuf[inptr++] : fill_inbuf(1))
+
+--- gzip-1.3.5/inflate.c
++++ gzip-1.3.5/inflate.c
+@@ -337,7 +337,7 @@
+ {
+ *t = (struct huft *)NULL;
+ *m = 0;
+- return 0;
++ return 2;
+ }
+
+
+--- gzip-1.3.5/unlzh.c
++++ gzip-1.3.5/unlzh.c
+@@ -149,13 +149,17 @@
+ unsigned i, k, len, ch, jutbits, avail, nextcode, mask;
+
+ for (i = 1; i <= 16; i++) count[i] = 0;
+- for (i = 0; i < (unsigned)nchar; i++) count[bitlen[i]]++;
++ for (i = 0; i < (unsigned)nchar; i++) {
++ if (bitlen[i] > 16)
++ error("Bad table (case a)\n");
++ else count[bitlen[i]]++;
++ }
+
+ start[1] = 0;
+ for (i = 1; i <= 16; i++)
+ start[i + 1] = start[i] + (count[i] << (16 - i));
+- if ((start[17] & 0xffff) != 0)
+- error("Bad table\n");
++ if ((start[17] & 0xffff) != 0 || tablebits > 16) /* 16 for weight below */
++ error("Bad table (case b)\n");
+
+ jutbits = 16 - tablebits;
+ for (i = 1; i <= (unsigned)tablebits; i++) {
+@@ -169,15 +173,15 @@
+
+ i = start[tablebits + 1] >> jutbits;
+ if (i != 0) {
+- k = 1 << tablebits;
+- while (i != k) table[i++] = 0;
++ k = MIN(1 << tablebits, DIST_BUFSIZE);
++ while (i < k) table[i++] = 0;
+ }
+
+ avail = nchar;
+ mask = (unsigned) 1 << (15 - tablebits);
+ for (ch = 0; ch < (unsigned)nchar; ch++) {
+ if ((len = bitlen[ch]) == 0) continue;
+- nextcode = start[len] + weight[len];
++ nextcode = MIN(start[len] + weight[len], DIST_BUFSIZE);
+ if (len <= (unsigned)tablebits) {
+ for (i = start[len]; i < nextcode; i++) table[i] = ch;
+ } else {
+@@ -218,7 +222,7 @@
+ for (i = 0; i < 256; i++) pt_table[i] = c;
+ } else {
+ i = 0;
+- while (i < n) {
++ while (i < MIN(n,NPT)) {
+ c = bitbuf >> (BITBUFSIZ - 3);
+ if (c == 7) {
+ mask = (unsigned) 1 << (BITBUFSIZ - 1 - 3);
+@@ -228,7 +232,7 @@
+ pt_len[i++] = c;
+ if (i == i_special) {
+ c = getbits(2);
+- while (--c >= 0) pt_len[i++] = 0;
++ while (--c >= 0 && i < NPT) pt_len[i++] = 0;
+ }
+ }
+ while (i < nn) pt_len[i++] = 0;
+@@ -248,7 +252,7 @@
+ for (i = 0; i < 4096; i++) c_table[i] = c;
+ } else {
+ i = 0;
+- while (i < n) {
++ while (i < MIN(n,NC)) {
+ c = pt_table[bitbuf >> (BITBUFSIZ - 8)];
+ if (c >= NT) {
+ mask = (unsigned) 1 << (BITBUFSIZ - 1 - 8);
+@@ -256,14 +260,14 @@
+ if (bitbuf & mask) c = right[c];
+ else c = left [c];
+ mask >>= 1;
+- } while (c >= NT);
++ } while (c >= NT && (mask || c != left[c]));
+ }
+ fillbuf((int) pt_len[c]);
+ if (c <= 2) {
+ if (c == 0) c = 1;
+ else if (c == 1) c = getbits(4) + 3;
+ else c = getbits(CBIT) + 20;
+- while (--c >= 0) c_len[i++] = 0;
++ while (--c >= 0 && i < NC) c_len[i++] = 0;
+ } else c_len[i++] = c - 2;
+ }
+ while (i < NC) c_len[i++] = 0;
+@@ -292,7 +296,7 @@
+ if (bitbuf & mask) j = right[j];
+ else j = left [j];
+ mask >>= 1;
+- } while (j >= NC);
++ } while (j >= NC && (mask || j != left[j]));
+ }
+ fillbuf((int) c_len[j]);
+ return j;
+@@ -309,7 +313,7 @@
+ if (bitbuf & mask) j = right[j];
+ else j = left [j];
+ mask >>= 1;
+- } while (j >= NP);
++ } while (j >= NP && (mask || j != left[j]));
+ }
+ fillbuf((int) pt_len[j]);
+ if (j != 0) j = ((unsigned) 1 << (j - 1)) + getbits((int) (j - 1));
+@@ -356,7 +360,7 @@
+ while (--j >= 0) {
+ buffer[r] = buffer[i];
+ i = (i + 1) & (DICSIZ - 1);
+- if (++r == count) return r;
++ if (++r >= count) return r;
+ }
+ for ( ; ; ) {
+ c = decode_c();
+@@ -366,14 +370,14 @@
+ }
+ if (c <= UCHAR_MAX) {
+ buffer[r] = c;
+- if (++r == count) return r;
++ if (++r >= count) return r;
+ } else {
+ j = c - (UCHAR_MAX + 1 - THRESHOLD);
+ i = (r - decode_p() - 1) & (DICSIZ - 1);
+ while (--j >= 0) {
+ buffer[r] = buffer[i];
+ i = (i + 1) & (DICSIZ - 1);
+- if (++r == count) return r;
++ if (++r >= count) return r;
+ }
+ }
+ }
+--- gzip-1.3.5/unpack.c
++++ gzip-1.3.5/unpack.c
+@@ -13,7 +13,6 @@
+ #include "gzip.h"
+ #include "crypt.h"
+
+-#define MIN(a,b) ((a) <= (b) ? (a) : (b))
+ /* The arguments must not have side effects. */
+
+ #define MAX_BITLEN 25
+@@ -133,7 +132,7 @@
+ /* Remember where the literals of this length start in literal[] : */
+ lit_base[len] = base;
+ /* And read the literals: */
+- for (n = leaves[len]; n > 0; n--) {
++ for (n = leaves[len]; n > 0 && base < LITERALS; n--) {
+ literal[base++] = (uch)get_byte();
+ }
+ }
+@@ -169,7 +168,7 @@
+ prefixp = &prefix_len[1<<peek_bits];
+ for (len = 1; len <= peek_bits; len++) {
+ int prefixes = leaves[len] << (peek_bits-len); /* may be 0 */
+- while (prefixes--) *--prefixp = (uch)len;
++ while (prefixes-- && prefixp > prefix_len) *--prefixp = (uch)len;
+ }
+ /* The length of all other codes is unknown: */
+ while (prefixp > prefix_len) *--prefixp = 0;
diff --git a/app-arch/gzip/gzip-1.3.5-r9.ebuild b/app-arch/gzip/gzip-1.3.5-r9.ebuild
index fef4993e4296..b0c5478fd740 100644
--- a/app-arch/gzip/gzip-1.3.5-r9.ebuild
+++ b/app-arch/gzip/gzip-1.3.5-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r9.ebuild,v 1.4 2006/09/20 17:58:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r9.ebuild,v 1.5 2006/09/20 23:09:40 vapier Exp $
inherit eutils flag-o-matic
@@ -21,7 +21,7 @@ PROVIDE="virtual/gzip"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/CVE-2006-4334-8.diff
+ epatch "${FILESDIR}"/${P}-CVE-2006-4334-8.patch
epatch "${FILESDIR}"/${P}-debian.patch
epatch "${FILESDIR}"/${P}-znew-tempfile-2.patch
epatch "${FILESDIR}"/${P}-gunzip-dir.patch