summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-07-19 07:34:43 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-07-19 07:34:43 +0000
commitad48b559f9654468d2c7346d175fa74d40e187b5 (patch)
treed5e61a4493a11938486a7de2db330c686909440d /app-admin
parentversion bump and added gnuconfig_updade call, needed for atleast uclibc and m... (diff)
downloadhistorical-ad48b559f9654468d2c7346d175fa74d40e187b5.tar.gz
historical-ad48b559f9654468d2c7346d175fa74d40e187b5.tar.bz2
historical-ad48b559f9654468d2c7346d175fa74d40e187b5.zip
version bump.bug #55270
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/autopsy/ChangeLog7
-rw-r--r--app-admin/autopsy/Manifest16
-rw-r--r--app-admin/autopsy/autopsy-2.01.ebuild60
-rw-r--r--app-admin/autopsy/files/digest-autopsy-2.011
4 files changed, 81 insertions, 3 deletions
diff --git a/app-admin/autopsy/ChangeLog b/app-admin/autopsy/ChangeLog
index 6d2f01332ca1..3fd39e74fbd4 100644
--- a/app-admin/autopsy/ChangeLog
+++ b/app-admin/autopsy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/autopsy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/autopsy/ChangeLog,v 1.7 2004/06/25 14:58:27 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/autopsy/ChangeLog,v 1.8 2004/07/19 07:34:43 dragonheart Exp $
+
+*autopsy-2.01 (19 Jul 2004)
+
+ 19 Jul 2004; Daniel Black <dragonheart@gentoo.org> +autopsy-2.01.ebuild:
+ version bump. Thank to Antek Grzymala <awaria@chopin.edu.pl> in bug #55270
25 Jun 2004; Ferris McCormick <fmccor@gentoo.org> autopsy-2.00.ebuild:
Marked stable for sparc.
diff --git a/app-admin/autopsy/Manifest b/app-admin/autopsy/Manifest
index 9f1a90ba4ac2..8818e9734a63 100644
--- a/app-admin/autopsy/Manifest
+++ b/app-admin/autopsy/Manifest
@@ -1,5 +1,17 @@
-MD5 188e675ce6c45147f2f5941356ec981e ChangeLog 919
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 e96787b73921c43f02ecea357cabddc0 autopsy-2.00.ebuild 1396
+MD5 7a21dc8786abeffcc827143198c65a6a ChangeLog 1106
MD5 6d796b061ed1c1337ef157a5f74dab35 metadata.xml 403
-MD5 7acbb37db527316691b7d21cb904a0ae files/autopsy.pl 663
+MD5 7c777d12a10695acc3d01789eb9dfae0 autopsy-2.01.ebuild 1451
MD5 c05a3215316f445eab678356bd2c3327 files/digest-autopsy-2.00 64
+MD5 7acbb37db527316691b7d21cb904a0ae files/autopsy.pl 663
+MD5 18d57e36340f7d07de759a1cc1b6bc79 files/digest-autopsy-2.01 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFA+3tbmdTrptrqvGERAtLzAJsEEuJ2k34ciFisX9mQ+rrjXoO5AACfYCK4
+w4DMmTIN2r0AthJ5eN0zw1Q=
+=Wiuw
+-----END PGP SIGNATURE-----
diff --git a/app-admin/autopsy/autopsy-2.01.ebuild b/app-admin/autopsy/autopsy-2.01.ebuild
new file mode 100644
index 000000000000..19a8a6fb5196
--- /dev/null
+++ b/app-admin/autopsy/autopsy-2.01.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/autopsy/autopsy-2.01.ebuild,v 1.1 2004/07/19 07:34:43 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
+SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
+HOMEPAGE="http://www.sleuthkit.org/autopsy/"
+RESTRICT="nomirror"
+
+KEYWORDS="~x86 ~sparc ~s390"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+# Runtime depend on grep and file deliberate
+
+RDEPEND="dev-lang/perl
+ app-admin/sleuthkit
+ sys-apps/grep
+ sys-apps/file"
+
+DEPEND="dev-lang/perl
+ app-admin/sleuthkit
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ echo "#!/usr/bin/perl -wT" > autopsy
+ echo "use lib '/usr/lib/autopsy/';" >> autopsy
+ echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
+ cat base/autopsy.base >> autopsy
+ sed -i 's:conf.pl:/etc/autopsy.pl:' autopsy lib/Main.pm
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ insinto /usr/lib/autopsy
+ doins autopsy
+ insinto /usr/lib/autopsy/help
+ doins help/*
+ insinto /usr/lib/autopsy/lib
+ doins lib/*
+ insinto /usr/lib/autopsy/pict
+ doins pict/*
+ insinto /etc
+ doins ${FILESDIR}/autopsy.pl
+
+ dodir /usr/bin
+ dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
+ fperms +x /usr/lib/autopsy/autopsy
+
+ doman man/man1/autopsy.1
+ dodoc CHANGES.txt README.txt TODO.txt docs/sleuthkit-informer-13.txt
+}
diff --git a/app-admin/autopsy/files/digest-autopsy-2.01 b/app-admin/autopsy/files/digest-autopsy-2.01
new file mode 100644
index 000000000000..b42b2e90a299
--- /dev/null
+++ b/app-admin/autopsy/files/digest-autopsy-2.01
@@ -0,0 +1 @@
+MD5 a754189ea0804efbc9709f26cd9f58cf autopsy-2.01.tar.gz 346261