summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-22 00:27:49 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-22 00:27:49 +0000
commitaba508362edd836c3573444cc074747d3674f76a (patch)
treedb92024c26f9fc64380fdea6dba81d26b8eaa486 /app-admin/tftp-hpa
parentNew ebuild. Resolves bug #1958 (diff)
downloadhistorical-aba508362edd836c3573444cc074747d3674f76a.tar.gz
historical-aba508362edd836c3573444cc074747d3674f76a.tar.bz2
historical-aba508362edd836c3573444cc074747d3674f76a.zip
New package. Closes (#1877)
Diffstat (limited to 'app-admin/tftp-hpa')
-rw-r--r--app-admin/tftp-hpa/ChangeLog9
-rw-r--r--app-admin/tftp-hpa/files/digest-tftp-hpa-0.291
-rw-r--r--app-admin/tftp-hpa/files/in.tftpd.confd5
-rw-r--r--app-admin/tftp-hpa/files/in.tftpd.rc621
-rw-r--r--app-admin/tftp-hpa/tftp-hpa-0.29.ebuild26
5 files changed, 61 insertions, 1 deletions
diff --git a/app-admin/tftp-hpa/ChangeLog b/app-admin/tftp-hpa/ChangeLog
index 096af7b5c2ef..e223d71ed43e 100644
--- a/app-admin/tftp-hpa/ChangeLog
+++ b/app-admin/tftp-hpa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/tftp-hpa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tftp-hpa/ChangeLog,v 1.1 2002/02/01 21:52:59 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tftp-hpa/ChangeLog,v 1.2 2002/04/22 00:27:29 rphillips Exp $
+
+*tftp-hpa-0.29 (19 Apr 2002)
+
+ 19 Apr 2002; J.Ritchie <jasonr@myrealbox.com> ChangeLog :
+
+ Updated to work with newest tftp-hpa version.
+ Added /etc/conf.d and /etc/init.d scripts for use with rc-update.
*tftp-hpa-0.16 (1 Feb 2002)
diff --git a/app-admin/tftp-hpa/files/digest-tftp-hpa-0.29 b/app-admin/tftp-hpa/files/digest-tftp-hpa-0.29
new file mode 100644
index 000000000000..9e63ff6f1a6a
--- /dev/null
+++ b/app-admin/tftp-hpa/files/digest-tftp-hpa-0.29
@@ -0,0 +1 @@
+MD5 a3ea7ac1bee61ea3baf3956360b6e787 tftp-hpa-0.29.tar.bz2 76088
diff --git a/app-admin/tftp-hpa/files/in.tftpd.confd b/app-admin/tftp-hpa/files/in.tftpd.confd
new file mode 100644
index 000000000000..655359aab1bf
--- /dev/null
+++ b/app-admin/tftp-hpa/files/in.tftpd.confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/in.tftpd
+# Remove the -l if you use [x]inetd
+
+INTFTPD_PATH="/"
+INTFTPD_OPTS="-l ${INTFTPD_PATH}"
diff --git a/app-admin/tftp-hpa/files/in.tftpd.rc6 b/app-admin/tftp-hpa/files/in.tftpd.rc6
new file mode 100644
index 000000000000..7290b23ee5ca
--- /dev/null
+++ b/app-admin/tftp-hpa/files/in.tftpd.rc6
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/fakeidentd/files/fakeidentd.rc6,v 1.3 2002/04/01 19:51:09 woodchip Exp
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting in.tftpd"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/in.tftpd -- ${INTFTPD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping in.tftpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/in.tftpd
+ eend $?
+}
diff --git a/app-admin/tftp-hpa/tftp-hpa-0.29.ebuild b/app-admin/tftp-hpa/tftp-hpa-0.29.ebuild
new file mode 100644
index 000000000000..793a5087beff
--- /dev/null
+++ b/app-admin/tftp-hpa/tftp-hpa-0.29.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tftp-hpa/tftp-hpa-0.29.ebuild,v 1.1 2002/04/22 00:27:30 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HPA's TFTP Daemon is a port of the OpenBSD TFTP server"
+SRC_URI="ftp://ftp.kernel.org/pub/software/network/tftp/${P}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/software/network/tftp/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} || die
+ make || die
+}
+
+src_install () {
+ make INSTALLROOT=${D} install || die
+ dodoc README* CHANGES INSTALL*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/in.tftpd.confd in.tftpd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/in.tftpd.rc6 in.tftpd
+}