summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 05:03:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 05:03:58 +0000
commit4cf02fd2ceae595d826f55c23fa8c39941b3a197 (patch)
tree09350298979fe54f498bfcc872119fd8437ff607 /app-admin/reportmagic/reportmagic-2.21.ebuild
parentStability for the x86 (diff)
downloadhistorical-4cf02fd2ceae595d826f55c23fa8c39941b3a197.tar.gz
historical-4cf02fd2ceae595d826f55c23fa8c39941b3a197.tar.bz2
historical-4cf02fd2ceae595d826f55c23fa8c39941b3a197.zip
fix DESCRIPTION - Peter Jensen (bug #51382); error check sed; tidy
Diffstat (limited to 'app-admin/reportmagic/reportmagic-2.21.ebuild')
-rw-r--r--app-admin/reportmagic/reportmagic-2.21.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-admin/reportmagic/reportmagic-2.21.ebuild b/app-admin/reportmagic/reportmagic-2.21.ebuild
index 275864d34d32..7ed4e66bd41f 100644
--- a/app-admin/reportmagic/reportmagic-2.21.ebuild
+++ b/app-admin/reportmagic/reportmagic-2.21.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/reportmagic/reportmagic-2.21.ebuild,v 1.2 2004/04/28 21:34:52 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/reportmagic/reportmagic-2.21.ebuild,v 1.3 2004/05/25 05:03:58 mr_bones_ Exp $
-DESCRIPTION="This is a sample skeleton ebuild file"
+DESCRIPTION="Makes usable statistics from your web site log file analysis"
HOMEPAGE="http://www.reportmagic.org"
SRC_URI="http://www.reportmagic.org/rmagic-${PV}.tar.gz"
+
LICENSE="Artistic"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="truetype"
+
DEPEND="sys-libs/zlib
media-libs/libpng
media-libs/libgd
@@ -22,17 +24,19 @@ DEPEND="sys-libs/zlib
dev-perl/GDGraph
dev-perl/File-Temp
dev-perl/GD-Graph3d"
-S=${WORKDIR}/rmagic-${PV}
+
+S="${WORKDIR}/rmagic-${PV}"
src_unpack() {
unpack ${A} ; cd ${S}
- sed -i -e "s:^\$DEST.*:\$DEST='${D}/usr/share/reportmagic';:g" \
+ sed -i \
+ -e "s:^\$DEST.*:\$DEST='${D}/usr/share/reportmagic';:g" \
-e "s:^\$DOC.*:\$DOC='${D}/usr/share/doc/${PF}';:g" \
- Install.PL
+ Install.PL \
+ || die "sed failed"
}
src_install() {
perl Install.PL -no_modules
}
-