summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-11-06 22:42:31 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-11-06 22:42:31 +0000
commit30f116385638d2d6c03e13ee8de01ca08b836ac1 (patch)
treebea519e51204ca86965e462a8fb91e7b5d52d800 /app-admin/pwgen/pwgen-2.06.ebuild
parentRemove UT from the comments on games_ut_unpack due to bug #196142. (diff)
downloadhistorical-30f116385638d2d6c03e13ee8de01ca08b836ac1.tar.gz
historical-30f116385638d2d6c03e13ee8de01ca08b836ac1.tar.bz2
historical-30f116385638d2d6c03e13ee8de01ca08b836ac1.zip
Version bump. Thanks to Raúl Porcel <armin76@gentoo.org> for pointing it out. Closing bug #197222.
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'app-admin/pwgen/pwgen-2.06.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.06.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.06.ebuild b/app-admin/pwgen/pwgen-2.06.ebuild
new file mode 100644
index 000000000000..2ff627d13e38
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.06.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.06.ebuild,v 1.1 2007/11/06 22:42:30 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="livecd"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/pwgen || die "econf failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}