summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-01 19:53:13 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-01 19:53:13 +0000
commitf33153b7d34a8b25a8b5af52fb2b10369ccd665c (patch)
tree892d96ff10b0556c0dc86ffdb3060de8fa8a28a3 /app-admin/fam-oss
parentnew version (diff)
downloadhistorical-f33153b7d34a8b25a8b5af52fb2b10369ccd665c.tar.gz
historical-f33153b7d34a8b25a8b5af52fb2b10369ccd665c.tar.bz2
historical-f33153b7d34a8b25a8b5af52fb2b10369ccd665c.zip
fam added
Diffstat (limited to 'app-admin/fam-oss')
-rw-r--r--app-admin/fam-oss/fam-oss-2.6.4.ebuild42
-rw-r--r--app-admin/fam-oss/files/digest-fam-oss-2.6.41
-rw-r--r--app-admin/fam-oss/files/fam20
-rw-r--r--app-admin/fam-oss/files/fam-oss-2.6.4-gentoo.patch12
4 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/fam-oss/fam-oss-2.6.4.ebuild b/app-admin/fam-oss/fam-oss-2.6.4.ebuild
new file mode 100644
index 000000000000..5f2235afbb44
--- /dev/null
+++ b/app-admin/fam-oss/fam-oss-2.6.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joshua Pierre <joshua@swool.com>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fam-oss/fam-oss-2.6.4.ebuild,v 1.1 2001/12/01 19:53:13 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="fam, the File Alteration Monitor."
+SRC_URI=ftp://oss.sgi.com/projects/fam/download/${P}.tar.gz""
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+
+DEPEND=">=sys-devel/perl-5.6.1"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fam
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS TODO README*
+}
diff --git a/app-admin/fam-oss/files/digest-fam-oss-2.6.4 b/app-admin/fam-oss/files/digest-fam-oss-2.6.4
new file mode 100644
index 000000000000..2c6a3fb1c839
--- /dev/null
+++ b/app-admin/fam-oss/files/digest-fam-oss-2.6.4
@@ -0,0 +1 @@
+MD5 d060919b3d9ede61a8b68eae1ded53ce fam-oss-2.6.4.tar.gz 241664
diff --git a/app-admin/fam-oss/files/fam b/app-admin/fam-oss/files/fam
new file mode 100644
index 000000000000..67447da940d5
--- /dev/null
+++ b/app-admin/fam-oss/files/fam
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+depend() {
+ need portmap
+}
+
+
+start() {
+ ebegin "Starting fam"
+ #for some reason dont want to daemonize without the '&'
+ start-stop-daemon --start --quiet --exec /usr/bin/fam \
+ -- -T 0 -c /etc/fam.conf &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping fam"
+ start-stop-daemon --stop --quiet --exec /usr/bin/fam
+ eend $?
+}
diff --git a/app-admin/fam-oss/files/fam-oss-2.6.4-gentoo.patch b/app-admin/fam-oss/files/fam-oss-2.6.4-gentoo.patch
new file mode 100644
index 000000000000..172b3391e759
--- /dev/null
+++ b/app-admin/fam-oss/files/fam-oss-2.6.4-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur fam-oss-2.6.4.vanilla/include/BTree.h fam-oss-2.6.4/include/BTree.h
+--- fam-oss-2.6.4.vanilla/include/BTree.h Sat May 20 12:46:32 2000
++++ fam-oss-2.6.4/include/BTree.h Tue Oct 16 03:25:41 2001
+@@ -22,7 +22,7 @@
+
+ #ifndef BTree_included
+ #define BTree_included
+-
++#include <stdio.h>
+ #include "Boolean.h"
+
+ // This is an in-core B-Tree implementation.