summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-04-08 13:06:52 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-04-08 13:06:52 +0000
commit3c1d6c37f789319ad04149571e932efbbae59220 (patch)
treeb5cda7f47e066b6d251c20b1f0bf209195534624 /app-admin/authbind/files
parentRemove old. (diff)
downloadhistorical-3c1d6c37f789319ad04149571e932efbbae59220.tar.gz
historical-3c1d6c37f789319ad04149571e932efbbae59220.tar.bz2
historical-3c1d6c37f789319ad04149571e932efbbae59220.zip
Initial commit for bug #74301, ebuild written by me.
Package-Manager: portage-2.1.11.58/cvs/Linux x86_64 Manifest-Sign-Key: 0x1E0CA85F!
Diffstat (limited to 'app-admin/authbind/files')
-rw-r--r--app-admin/authbind/files/authbind-2.1.1-respect-flags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
new file mode 100644
index 000000000000..2a9eb5f6b84c
--- /dev/null
+++ b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c1eed73..932ea60 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
+ INSTALL_DIR ?= install -o root -g root -m 755 -d
+ STRIP ?= strip
+
+-OPTIMISE= -O2
+-LDFLAGS= -g
+ LIBS= -ldl -lc
+-CFLAGS= -g $(OPTIMISE) \
++SHARED_LDFLAGS=
++CFLAGS+= \
+ -Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
+ -Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
+ CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
+@@ -82,7 +81,7 @@ helper: helper.o
+ helper.o authbind.o: authbind.h
+
+ $(LIBTARGET): libauthbind.o
+- ld -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
++ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+
+ clean distclean:
+ rm -f $(TARGETS) *.o *~ ./#*# *.bak *.new core