summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-07-01 11:53:30 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-07-01 11:53:30 +0000
commited95f8b5eb6daf315343c6007d077b57bfdbbbbd (patch)
treeb1a0fa695ae03a863546507181a394061a01e1b2
parent* stable on amd64 and x86 (diff)
downloadhistorical-ed95f8b5eb6daf315343c6007d077b57bfdbbbbd.tar.gz
historical-ed95f8b5eb6daf315343c6007d077b57bfdbbbbd.tar.bz2
historical-ed95f8b5eb6daf315343c6007d077b57bfdbbbbd.zip
Version bump to 2.1.1 and fix of 64bit detection.
Package-Manager: portage-2.0.51.22-r1
-rw-r--r--dev-lang/R/ChangeLog9
-rw-r--r--dev-lang/R/Manifest18
-rw-r--r--dev-lang/R/R-2.0.1.ebuild9
-rw-r--r--dev-lang/R/R-2.1.0-r1.ebuild9
-rw-r--r--dev-lang/R/R-2.1.1.ebuild87
-rw-r--r--dev-lang/R/files/digest-R-2.1.11
6 files changed, 125 insertions, 8 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 87895cfddae7..79688bd266d3 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.55 2005/06/18 14:40:27 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.56 2005/07/01 11:53:30 kugelfang Exp $
+
+*R-2.1.1 (01 Jul 2005)
+
+ 01 Jul 2005; Danny van Dyk <kugelfang@gentoo.org> R-2.0.1.ebuild,
+ R-2.1.0-r1.ebuild, +R-2.1.1.ebuild:
+ Moved 64bit check to pkg_setup() to make fortran.eclass work again. Bumped
+ to version 2.1.1
18 Jun 2005; Markus Rothe <corsair@gentoo.org> R-2.1.0-r1.ebuild:
Stable on ppc64
diff --git a/dev-lang/R/Manifest b/dev-lang/R/Manifest
index c8d28baf1570..8fd952921875 100644
--- a/dev-lang/R/Manifest
+++ b/dev-lang/R/Manifest
@@ -1,8 +1,20 @@
-MD5 a49486f687b24c40a13e9f86d74d8a75 ChangeLog 8463
-MD5 a182d325b0bce4efd708b2ebc3ecfaed R-2.0.1.ebuild 3691
-MD5 fb222162efe0cf2b44caf11f127e2892 R-2.1.0-r1.ebuild 2596
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 07eb317545d872a3967a256da22ae559 R-2.1.1.ebuild 2661
+MD5 54a2c33b1f528a94b8d07cc247a05e39 ChangeLog 8692
+MD5 fc5ae27d8f8ad03adc952dc27fe62c8b R-2.1.0-r1.ebuild 2659
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 a3da9043771f68dc08167f298bcaccef R-2.0.1.ebuild 3753
+MD5 1be6338417fd08a609cb02164398a26b files/digest-R-2.1.1 61
MD5 44015fe4137f1326769e89f2c2c2eda7 files/R-logo.png 4867
MD5 15ce6e575cf7a5844aa8deecb504e7be files/R.desktop 425
MD5 eec0037e7f2073028a10b5028ee8b0bc files/digest-R-2.0.1 61
MD5 35b08f0bf56b91051f76faa75d70eb9f files/digest-R-2.1.0-r1 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCxS+x5mJXAu5GbtIRArHPAJ0dqh+ow3Wmxzu9AwJXoNLjuVIKEACfc/Kz
+365x9mTGCRaVED807kYS7kY=
+=xEmv
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/R/R-2.0.1.ebuild b/dev-lang/R/R-2.0.1.ebuild
index 2d0262f54f0a..1d2ad9b9eada 100644
--- a/dev-lang/R/R-2.0.1.ebuild
+++ b/dev-lang/R/R-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.0.1.ebuild,v 1.7 2005/06/07 14:28:22 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.0.1.ebuild,v 1.8 2005/07/01 11:53:30 kugelfang Exp $
inherit fortran toolchain-funcs
@@ -34,7 +34,7 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-src_compile() {
+pkg_setup() {
# Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
# Thanks to vapier for providing the test.
echo 'int main(){}' > test.c
@@ -42,8 +42,13 @@ src_compile() {
if file test.o | grep -qs 64-bit ; then
einfo "64 bit architecture detected, using g77."
FORTRAN="g77"
+ else
+ FORTRAN="g77 f2c"
fi
+ fortran_pkg_setup
+}
+src_compile() {
local myconf="--enable-static --enable-R-profiling --enable-R-shlib --with-readline"
use zlib || myconf="${myconf} --with-zlib" #default disabled
diff --git a/dev-lang/R/R-2.1.0-r1.ebuild b/dev-lang/R/R-2.1.0-r1.ebuild
index 59dcba8af112..7ec036a14b27 100644
--- a/dev-lang/R/R-2.1.0-r1.ebuild
+++ b/dev-lang/R/R-2.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.0-r1.ebuild,v 1.8 2005/06/18 14:40:27 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.0-r1.ebuild,v 1.9 2005/07/01 11:53:30 kugelfang Exp $
inherit fortran toolchain-funcs
@@ -22,7 +22,7 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-src_compile() {
+pkg_setup() {
# Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
# Thanks to vapier for providing the test.
echo 'int main(){}' > test.c
@@ -30,8 +30,13 @@ src_compile() {
if file test.o | grep -qs 64-bit ; then
einfo "64 bit architecture detected, using g77."
FORTRAN="g77"
+ else
+ FORTRAN="g77 f2c"
fi
+ fortran_pkg_setup
+}
+src_compile() {
local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
if use tcltk; then
diff --git a/dev-lang/R/R-2.1.1.ebuild b/dev-lang/R/R-2.1.1.ebuild
new file mode 100644
index 000000000000..4078260be8a0
--- /dev/null
+++ b/dev-lang/R/R-2.1.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.1.ebuild,v 1.1 2005/07/01 11:53:30 kugelfang Exp $
+
+inherit fortran toolchain-funcs
+
+IUSE="blas jpeg nls png readline tcltk X"
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+SRC_URI="http://cran.r-project.org/src/base/R-2/${P}.tar.gz"
+#There are daily release patches, don't know how to utilize these
+#"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+HOMEPAGE="http://www.r-project.org/"
+DEPEND="virtual/libc
+ >=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77."
+ FORTRAN="g77"
+ else
+ FORTRAN="g77 f2c"
+ fi
+ fortran_pkg_setup
+}
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ rhome=${D}/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed"
+
+ #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ #the 2nd one is corrected by above sed, for the 1st
+ #I'll just symlink it into /usr/bin
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo > ${D}/etc/env.d/99R "LDPATH=/usr/$(get_libdir)/R/lib"
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+}
diff --git a/dev-lang/R/files/digest-R-2.1.1 b/dev-lang/R/files/digest-R-2.1.1
new file mode 100644
index 000000000000..0a5f7f2a5dbe
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.1.1
@@ -0,0 +1 @@
+MD5 e755b0ba5851ec261000af6b5c510335 R-2.1.1.tar.gz 12644376