summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2003-06-27 12:37:12 +0000
committerLars Weiler <pylon@gentoo.org>2003-06-27 12:37:12 +0000
commite6b81289307bf95f918bd089380c9f12fbba75fd (patch)
tree21cb4b6a4e32914902b2152c4775511c439cd18b
parentinitial import (diff)
downloadhistorical-e6b81289307bf95f918bd089380c9f12fbba75fd.tar.gz
historical-e6b81289307bf95f918bd089380c9f12fbba75fd.tar.bz2
historical-e6b81289307bf95f918bd089380c9f12fbba75fd.zip
initial import
-rw-r--r--media-libs/libvideogfx/Manifest4
-rw-r--r--media-libs/libvideogfx/files/digest-libvideogfx-1.0.31
-rw-r--r--media-libs/libvideogfx/libvideogfx-1.0.3.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/media-libs/libvideogfx/Manifest b/media-libs/libvideogfx/Manifest
index 013d7502d517..9d930db16c46 100644
--- a/media-libs/libvideogfx/Manifest
+++ b/media-libs/libvideogfx/Manifest
@@ -1,3 +1,3 @@
-MD5 a53fb25f942411d848c818bf59dbb358 libvideogfx-1.0.3.ebuild 860
-MD5 0e06aec947e3a648926d56435f000f8e ChangeLog 255
+MD5 ea11c865a9aeeb0389c8e31b957615f3 libvideogfx-1.0.3.ebuild 969
+MD5 d2d486dd625db8f8641b35f27dfdcf5d ChangeLog 349
MD5 1e9b50805cbff8580d46777b35d813a5 files/digest-libvideogfx-1.0.3 69
diff --git a/media-libs/libvideogfx/files/digest-libvideogfx-1.0.3 b/media-libs/libvideogfx/files/digest-libvideogfx-1.0.3
new file mode 100644
index 000000000000..cf2a1e3456c7
--- /dev/null
+++ b/media-libs/libvideogfx/files/digest-libvideogfx-1.0.3
@@ -0,0 +1 @@
+MD5 3a40559055e4eb8304888f54efb3b91f libvideogfx-1.0.3.tar.gz 332532
diff --git a/media-libs/libvideogfx/libvideogfx-1.0.3.ebuild b/media-libs/libvideogfx/libvideogfx-1.0.3.ebuild
new file mode 100644
index 000000000000..c131eb321521
--- /dev/null
+++ b/media-libs/libvideogfx/libvideogfx-1.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvideogfx/libvideogfx-1.0.3.ebuild,v 1.1 2003/06/27 12:37:03 pylon Exp $
+
+DESCRIPTION="LibVideoGfx is a C++ library for low-level video processing."
+HOMEPAGE="http://rachmaninoff.informatik.uni-mannheim.de/libvideogfx/index.html"
+SRC_URI="http://rachmaninoff.informatik.uni-mannheim.de/libvideogfx/data/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="1.0"
+
+KEYWORDS="~x86 ~ppc"
+
+IUSE="mpeg"
+
+DEPEND="virtual/glibc
+ x11-base/xfree"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+
+}