summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-03-12 18:59:48 +0000
committerPacho Ramos <pacho@gentoo.org>2011-03-12 18:59:48 +0000
commitc1f3e1e6714b5a00c387d7295e5da2d8d250256e (patch)
treecbb33ffb5da98ac644fd3b5408ef3cb11dd5798a
parentalpha/arm/ia64/sh/sparc stable wrt #353436 (diff)
downloadhistorical-c1f3e1e6714b5a00c387d7295e5da2d8d250256e.tar.gz
historical-c1f3e1e6714b5a00c387d7295e5da2d8d250256e.tar.bz2
historical-c1f3e1e6714b5a00c387d7295e5da2d8d250256e.zip
Build and install test utils conditionally (bug #226233), skip broken test as upstream doesn't care (bug #331709). Remove old.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
-rw-r--r--gnome-base/orbit/ChangeLog9
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r1.ebuild (renamed from gnome-base/orbit/orbit-2.14.17.ebuild)48
2 files changed, 43 insertions, 14 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 6287278294f9..79dd85195476 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.170 2011/01/30 18:53:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.171 2011/03/12 18:59:48 pacho Exp $
+
+*orbit-2.14.19-r1 (12 Mar 2011)
+
+ 12 Mar 2011; Pacho Ramos <pacho@gentoo.org> -orbit-2.14.17.ebuild,
+ +orbit-2.14.19-r1.ebuild:
+ Build and install test utils conditionally (bug #226233), skip broken test as
+ upstream doesn't care (bug #331709). Remove old.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> orbit-2.14.19.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #348987
diff --git a/gnome-base/orbit/orbit-2.14.17.ebuild b/gnome-base/orbit/orbit-2.14.19-r1.ebuild
index f62fdbfa16d3..1197fb54e559 100644
--- a/gnome-base/orbit/orbit-2.14.17.ebuild
+++ b/gnome-base/orbit/orbit-2.14.19-r1.ebuild
@@ -1,40 +1,60 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.13 2010/07/20 02:13:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r1.ebuild,v 1.1 2011/03/12 18:59:48 pacho Exp $
-EAPI="2"
-GCONF_DEBUG="no"
+EAPI="3"
+GCONF_DEBUG="yes"
-inherit gnome2 toolchain-funcs
+inherit gnome2 toolchain-funcs autotools
-MY_P="ORBit2-${PV}"
-PVP=(${PV//[-\._]/ })
+MY_PN="ORBit2"
+MY_P="${MY_PN}-${PV}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
HOMEPAGE="http://www.gnome.org/"
-SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="2"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
-RDEPEND=">=dev-libs/glib-2.8
+RDEPEND=">=dev-libs/glib-2.8:2
>=dev-libs/libIDL-0.8.2"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.18
doc? ( >=dev-util/gtk-doc-1 )"
-DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ if use test; then
+ if ! use debug; then
+ elog "USE=debug is required for the test feature. Auto-enabling."
+ fi
+ G2CONF="${G2CONF} --enable-debug"
+ fi
+}
src_prepare() {
gnome2_src_prepare
# Fix wrong process kill, bug #268142
sed "s:killall lt-timeout-server:killall timeout-server:" \
- -i test/timeout.sh || die "sed failed"
+ -i test/timeout.sh || die "sed 1 failed"
+
+ # Do not mess with CFLAGS
+ sed 's/-ggdb -O0//' -i configure.in configure || die "sed 2 failed"
+
+ if ! use test; then
+ sed -i -e 's/test //' Makefile.am || die
+ fi
+
+ # Drop failing test, bug #331709
+ sed -i -e 's/test-mem //' test/Makefile.am || die
+
+ eautoreconf
}
src_compile() {
@@ -50,6 +70,8 @@ src_compile() {
G2CONF="${G2CONF} --with-idl-compiler=/usr/bin/orbit-idl-2"
fi
+ # Parallel build fails from time to time, bug #273031
+ MAKEOPTS="${MAKEOPTS} -j1"
gnome2_src_compile
}