summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:40:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:40:50 +0000
commitb2385cf9a78a4ae1929c74bd78bb76230d720b9f (patch)
tree86cd388e1f0456049b975ebd8cfba17d08c18e36
parentNew version for GNOME 2.28. (diff)
downloadhistorical-b2385cf9a78a4ae1929c74bd78bb76230d720b9f.tar.gz
historical-b2385cf9a78a4ae1929c74bd78bb76230d720b9f.tar.bz2
historical-b2385cf9a78a4ae1929c74bd78bb76230d720b9f.zip
New version for GNOME 2.28.
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
-rw-r--r--www-client/epiphany-extensions/ChangeLog8
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.28.1.ebuild68
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.28.1.ebuild62
-rw-r--r--www-client/epiphany/metadata.xml3
5 files changed, 147 insertions, 2 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index 587b50abf139..dacec4cb707d 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.116 2009/10/03 14:21:09 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.117 2009/10/29 21:40:50 eva Exp $
+
+*epiphany-extensions-2.28.1 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-extensions-2.28.1.ebuild:
+ New version for GNOME 2.28.
03 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
epiphany-extensions-2.26.1.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.28.1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.28.1.ebuild
new file mode 100644
index 000000000000..cf98fab89393
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.28.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.28.1.ebuild,v 1.1 2009/10/29 21:40:50 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus examples pcre"
+
+RDEPEND=">=www-client/epiphany-${MY_MAJORV}
+ app-text/opensp
+ >=dev-libs/glib-2.15.5
+ >=gnome-base/gconf-2.0
+ >=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.12.0
+ >=gnome-base/libglade-2
+ >=net-libs/webkit-gtk-1.1
+
+ dbus? ( >=dev-libs/dbus-glib-0.34 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ >=app-text/gnome-doc-utils-0.3.2"
+# eautoreconf dependencies:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+# FIXME: Open security issues:
+# FIXME: - adblock ( https://bugzilla.gnome.org/show_bug.cgi?id=595255 )
+# FIXME: broken extensions:
+# FIXME: - gestures ( https://bugzilla.gnome.org/show_bug.cgi?id=563099 )
+# FIXME: - session-saver ( https://bugzilla.gnome.org/show_bug.cgi?id=316245 )
+# FIXME: - sidebar: hangs ( https://bugzilla.gnome.org/show_bug.cgi?id=594481 )
+
+pkg_setup() {
+ local extensions=""
+
+ extensions="actions auto-reload auto-scroller certificates \
+ error-viewer extensions-manager-ui \
+ java-console livehttpheaders page-info permissions \
+ push-scroller select-stylesheet \
+ smart-bookmarks soup-fly tab-groups tab-states"
+ use dbus && extensions="${extensions} rss"
+
+ use pcre && extensions="${extensions} greasemonkey"
+
+ use examples && extensions="${extensions} sample"
+
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 374184822390..15f83a8006c8 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.219 2009/10/22 17:27:49 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.220 2009/10/29 21:39:14 eva Exp $
+
+*epiphany-2.28.1 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.28.1.ebuild, metadata.xml:
+ New version for GNOME 2.28.
*epiphany-2.26.3-r2 (22 Oct 2009)
diff --git a/www-client/epiphany/epiphany-2.28.1.ebuild b/www-client/epiphany/epiphany-2.28.1.ebuild
new file mode 100644
index 000000000000..59d6dfbc6062
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.28.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.28.1.ebuild,v 1.1 2009/10/29 21:39:14 eva Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi doc networkmanager +nss test"
+# introspection
+
+# TODO: add seed support
+# not mature enough
+# introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+RDEPEND=">=dev-libs/glib-2.19.7
+ >=x11-libs/gtk+-2.16
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.1.15
+ >=net-libs/libsoup-2.27.91[gnome]
+ >=gnome-base/gnome-keyring-2.26.0
+
+ x11-libs/libICE
+ x11-libs/libSM
+
+ nss? ( dev-libs/nss )
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ gnome-base/gnome-common
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-introspection
+ --disable-scrollkeeper
+ --disable-maintainer-mode
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable nss)
+ $(use_enable test tests)"
+# $(use_enable introspection)
+}
diff --git a/www-client/epiphany/metadata.xml b/www-client/epiphany/metadata.xml
index da6fd63d0085..72b304a074f2 100644
--- a/www-client/epiphany/metadata.xml
+++ b/www-client/epiphany/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
+<use>
+ <flag name="nss">Import passwords from older gecko based <pkg>www-client/epiphany</pkg> keyring.</flag>
+</use>
</pkgmetadata>