summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-20 22:09:15 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-20 22:09:15 +0000
commit922da9cdca23321ad86dd95fc5f64ce50e68d7ee (patch)
tree89d684714aad08720b0ff681f881763005e40038
parentSwitch to new virtual/opencl #392179 by Michal Pytasz. (diff)
downloadhistorical-922da9cdca23321ad86dd95fc5f64ce50e68d7ee.tar.gz
historical-922da9cdca23321ad86dd95fc5f64ce50e68d7ee.tar.bz2
historical-922da9cdca23321ad86dd95fc5f64ce50e68d7ee.zip
Drop ATI from dep list for now since that only provides the libraries and not the required headers #392179#2 by Emil Karlson.
Package-Manager: portage-2.2.0_alpha81/cvs/Linux x86_64
-rw-r--r--virtual/opencl/ChangeLog6
-rw-r--r--virtual/opencl/Manifest10
-rw-r--r--virtual/opencl/opencl-0.ebuild12
3 files changed, 18 insertions, 10 deletions
diff --git a/virtual/opencl/ChangeLog b/virtual/opencl/ChangeLog
index 9cd2fe9f29f6..7de2a68d8436 100644
--- a/virtual/opencl/ChangeLog
+++ b/virtual/opencl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for virtual/opencl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.1 2011/12/20 19:32:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.2 2011/12/20 22:09:15 vapier Exp $
+
+ 20 Dec 2011; Mike Frysinger <vapier@gentoo.org> opencl-0.ebuild:
+ Drop ATI from dep list for now since that only provides the libraries and not
+ the required headers #392179#2 by Emil Karlson.
*opencl-0 (20 Dec 2011)
diff --git a/virtual/opencl/Manifest b/virtual/opencl/Manifest
index 63fdaa09f351..8e9a004530f6 100644
--- a/virtual/opencl/Manifest
+++ b/virtual/opencl/Manifest
@@ -1,13 +1,13 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
-EBUILD opencl-0.ebuild 557 RMD160 11787ff9d697aad4c437b7e110b55c9a32607ef8 SHA1 9e802a2a9c0797a7bafc37df9c98f14a73ae5464 SHA256 9a5cd5d6f98301fb90a1ae9c86b6425a4f64a3a994908e5a7f3d7623f0d8fe25
-MISC ChangeLog 365 RMD160 f9544dafdaaad3f332b47054e0259b0f99671d45 SHA1 7fcfad7ef46291bf11313e0cf4b4ae4a5e17ed55 SHA256 92997e6b50194ab32a68d16c45f2f08b636a11fe4a16cc2f163f32eba8acf226
+EBUILD opencl-0.ebuild 662 RMD160 a6d9106090bc73de7e0d13f964effcf702e29746 SHA1 c04bc97e2af8ad4eb0f84692c6df835cfa94e1a4 SHA256 e4d195071832f268f5c310ceeac0bdc27728ac99b1ccf37dce2e1296e245b564
+MISC ChangeLog 563 RMD160 aa2dd37824bca3c9e8676a43f7e4856190b82ab0 SHA1 fa77721c3e624a171d1b40ca84f6edf440e00c90 SHA256 d73326fe95e263947a3266673baa0894b270efa8e32a6b63ba44d0f53a07a9a7
MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
-iF4EAREIAAYFAk7w4tsACgkQaC/OocHi7JaZiwD/Z8bGwDIJn4GifoZybr4LdDLx
-xWdsN9/YrRNX4H60dxwA/11qi8TR1/K65Zmx0hHseHuRKYQCOH/YicaoRZJ8zPOK
-=gHs6
+iF4EAREIAAYFAk7xB5YACgkQaC/OocHi7JaBaQD7BaRhiSRfKJobN4P/d3v9nRX5
+iPu3pmsok39XDCyok+4A/1Asq1jp5qHdqEK29eQixs2i5O5aBspCZpCRKwrUfeK9
+=W9al
-----END PGP SIGNATURE-----
diff --git a/virtual/opencl/opencl-0.ebuild b/virtual/opencl/opencl-0.ebuild
index 1318ce2d5b93..da2bb436fc79 100644
--- a/virtual/opencl/opencl-0.ebuild
+++ b/virtual/opencl/opencl-0.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/opencl-0.ebuild,v 1.1 2011/12/20 19:32:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/opencl-0.ebuild,v 1.2 2011/12/20 22:09:15 vapier Exp $
+
+# Until ATI's SDK is in the tree, nvidia is the only
+# viable provider #392179 #257626
EAPI="4"
DESCRIPTION="Virtual for OpenCL implementations"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-CARDS=( fglrx nvidia )
+KEYWORDS="amd64 x86"
+#CARDS=( fglrx nvidia )
+CARDS=( nvidia )
IUSE="${CARDS[@]/#/video_cards_}"
REQUIRED_USE="|| ( ${IUSE} )"
+# video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
RDEPEND="|| (
video_cards_nvidia? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
- video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
)"