summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-01-26 22:45:43 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-01-26 22:45:43 +0000
commit6c7e2ab9b69197e128f30da3771f02f90f4706e9 (patch)
treef49df964ce3ae3254d1aa3c6103fb0fe1114a55f
parentUpdated to latest version. This should be used for the 2005.0 release, as it... (diff)
downloadhistorical-6c7e2ab9b69197e128f30da3771f02f90f4706e9.tar.gz
historical-6c7e2ab9b69197e128f30da3771f02f90f4706e9.tar.bz2
historical-6c7e2ab9b69197e128f30da3771f02f90f4706e9.zip
closed bug #61251, added some dep., added possibility to compile tinylogic static or shared
-rw-r--r--sys-apps/tinylogin/ChangeLog8
-rw-r--r--sys-apps/tinylogin/Manifest12
-rw-r--r--sys-apps/tinylogin/tinylogin-1.4.ebuild23
3 files changed, 27 insertions, 16 deletions
diff --git a/sys-apps/tinylogin/ChangeLog b/sys-apps/tinylogin/ChangeLog
index 544e8b9b8271..2372c0eb7b47 100644
--- a/sys-apps/tinylogin/ChangeLog
+++ b/sys-apps/tinylogin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/tinylogin
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/ChangeLog,v 1.6 2004/07/01 21:41:24 eradicator Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/ChangeLog,v 1.7 2005/01/26 22:45:43 xmerlin Exp $
+
+ 27 Jan 2005; Christian Zoffoli <xmerlin@gentoo.org> tinylogin-1.4.ebuild:
+ closed bug #61251, added some dep., added possibility to compile tinylogic
+ static or shared
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> tinylogin-1.2.ebuild,
tinylogin-1.4.ebuild:
diff --git a/sys-apps/tinylogin/Manifest b/sys-apps/tinylogin/Manifest
index 8fe8754bac5e..cf0358d3babe 100644
--- a/sys-apps/tinylogin/Manifest
+++ b/sys-apps/tinylogin/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 cb85e903f4d15f8c8ad9790d2ba3c5a2 ChangeLog 658
+MD5 71885a785e5504e92717c1efa7d58ec5 tinylogin-1.4.ebuild 872
+MD5 6ab9985b34c2194ed85dc1aac39be895 ChangeLog 828
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 695a801aae172c24a6133375da2c4b36 tinylogin-1.4.ebuild 762
MD5 f205e4d830aea7ebd7633fc6ba5816ce files/digest-tinylogin-1.4 65
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
+Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBCb0pHTu7gpaalycRAiRMAKDXubtkSUeE41tjXYciHNY66Htg8gCfTIti
-myN4QTeM0qYN+ug8GV2vITQ=
-=odJs
+iD8DBQFB+HnagMUyd/cdjWsRAiOiAJ42BJrmIz0RcswYEhv5+BRTNy4gBACfVCWK
+ip31dCO/4VE6qx4VuN0+D4w=
+=msbe
-----END PGP SIGNATURE-----
diff --git a/sys-apps/tinylogin/tinylogin-1.4.ebuild b/sys-apps/tinylogin/tinylogin-1.4.ebuild
index 83e12b373d1a..5bcec6d00ed5 100644
--- a/sys-apps/tinylogin/tinylogin-1.4.ebuild
+++ b/sys-apps/tinylogin/tinylogin-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.7 2004/07/30 03:14:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.8 2005/01/26 22:45:43 xmerlin Exp $
DESCRIPTION="worlds smallest login/passwd/getty/etc"
HOMEPAGE="http://tinylogin.busybox.net/"
@@ -11,24 +11,31 @@ SLOT="0"
KEYWORDS="x86 arm amd64"
IUSE="static"
-DEPEND="virtual/libc"
+DEPEND="virtual/libc
+ !sys-apps/pam-login
+ !sys-apps/shadow
+ !sys-apps/sysvinit"
+
+RDEPEND="virtual/libc"
src_compile() {
local myconf=""
use static && myconf="${myconf} DOSTATIC=true"
+
+ append-ldflags -Wl,-z,now
emake ${myconf} || die
}
src_install() {
- into /
- dobin tinylogin || die
- into /usr
- dodoc Changelog README TODO
+ emake PREFIX=${D} install || die
+ doman docs/*.{1,8}
+
+ dodoc Changelog README TODO
cd docs
- doman *.1 *.8
dodoc *.txt
dohtml -r tinylogin.busybox.net
docinto pod
dodoc *.pod
}
+