summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-31 12:22:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-31 12:22:00 +0000
commit548913386689525647ccedb183e5e6f1ecbb3c91 (patch)
tree72c8b8610b0d24559baf65272e945e3b7665725b
parentStable on amd64 wrt bug #343399 (diff)
downloadhistorical-548913386689525647ccedb183e5e6f1ecbb3c91.tar.gz
historical-548913386689525647ccedb183e5e6f1ecbb3c91.tar.bz2
historical-548913386689525647ccedb183e5e6f1ecbb3c91.zip
Version bump
Package-Manager: portage-2.2_rc98/cvs/Linux x86_64
-rw-r--r--x11-misc/imake/ChangeLog7
-rw-r--r--x11-misc/imake/Manifest4
-rw-r--r--x11-misc/imake/imake-1.0.4.ebuild24
3 files changed, 33 insertions, 2 deletions
diff --git a/x11-misc/imake/ChangeLog b/x11-misc/imake/ChangeLog
index 3e198a62339e..f29fdf04b348 100644
--- a/x11-misc/imake/ChangeLog
+++ b/x11-misc/imake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/imake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/ChangeLog,v 1.38 2010/10/21 14:00:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/ChangeLog,v 1.39 2010/10/31 12:22:00 scarabeus Exp $
+
+*imake-1.0.4 (31 Oct 2010)
+
+ 31 Oct 2010; Tomáš Chvátal <scarabeus@gentoo.org> +imake-1.0.4.ebuild:
+ Version bump
21 Oct 2010; Tomáš Chvátal <scarabeus@gentoo.org> -imake-1.0.2.ebuild:
old
diff --git a/x11-misc/imake/Manifest b/x11-misc/imake/Manifest
index efcc53813c93..dc15622e5924 100644
--- a/x11-misc/imake/Manifest
+++ b/x11-misc/imake/Manifest
@@ -1,4 +1,6 @@
DIST imake-1.0.3.tar.bz2 139230 RMD160 5cbd5f23fc8360a10cb36c367405f5950443349d SHA1 625a974dd0fe4c4e9d7ec036fc7b079ec05185f1 SHA256 90015244dd7a32594162d2be6e934a258894d1ca2c37422ef727a7f1c0b553ea
+DIST imake-1.0.4.tar.bz2 140773 RMD160 186e364e9b5dc7cad504625c6c3ffe98bed45134 SHA1 23400fa4f5fa7601ccb00d11d17a58df473c8979 SHA256 acb27ff09e3083000441a8d555fbedbf35ecb4ad52d2bd5b8680dce853f146fe
EBUILD imake-1.0.3.ebuild 762 RMD160 ba01c5015775377f04e6dfa9782aecc547ed9bf0 SHA1 5cf08e24554ea770b51539399f904efced76b07c SHA256 44c22327807b9c8c42f9aa9df434c6d9235bb1215379c980015a155ce96dbc98
-MISC ChangeLog 4793 RMD160 965f8bcd538225a6a86fa2b3eaecfb2e14b856e2 SHA1 f2e091c9f8e1ebc83e8ac93b9f365a4ac256f0c2 SHA256 084d2b971c48d81cdac9f09aaa9dd79de9f5932f6289307bdd2ec5f5f2ccfca1
+EBUILD imake-1.0.4.ebuild 796 RMD160 87103abcc31bf6f65471b0b5fb56c56b801aa4bd SHA1 7772351340592d9fbd065aa87148375672e423b3 SHA256 e486d8af196cd35dcbf644974bd65592b8216a1b4b3d098b6e2bf7966329f5c0
+MISC ChangeLog 4913 RMD160 97ebdf92d0dacdb5c0c076e94f7e5b96cda2ba5f SHA1 3b7c7d6c28343dd204e43cdd666c119cb98425cb SHA256 7ed550300b3edd816657aa13d6d09ccbf63788535b18e20d6416a670ad59e8cc
MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
diff --git a/x11-misc/imake/imake-1.0.4.ebuild b/x11-misc/imake/imake-1.0.4.ebuild
new file mode 100644
index 000000000000..3780d0cbabc3
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/imake-1.0.4.ebuild,v 1.1 2010/10/31 12:22:00 scarabeus Exp $
+
+EAPI=3
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}