summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-05-06 20:05:00 +0200
committerSam James <sam@gentoo.org>2022-05-14 02:52:58 +0000
commit640425f827bb35eeaf51f1bfefa2eb24f1ed1f00 (patch)
tree1f5ddadab3b3039458458ef66b04a77441462292 /x11-wm
parentmate-extra/mate-polkit: add 1.26.0 (diff)
downloadgentoo-640425f827bb35eeaf51f1bfefa2eb24f1ed1f00.tar.gz
gentoo-640425f827bb35eeaf51f1bfefa2eb24f1ed1f00.tar.bz2
gentoo-640425f827bb35eeaf51f1bfefa2eb24f1ed1f00.zip
x11-wm/marco: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25304 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/marco/Manifest1
-rw-r--r--x11-wm/marco/marco-1.26.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/marco/Manifest b/x11-wm/marco/Manifest
index 5823e73ad23f..7f66b7d12fc9 100644
--- a/x11-wm/marco/Manifest
+++ b/x11-wm/marco/Manifest
@@ -1 +1,2 @@
DIST marco-1.24.2.tar.xz 1845356 BLAKE2B 9308e07fec5319f741f7d78007e68e916c407c515fc2076c0e26a760830d3c79edf39888f265f7edc1baf0c8dc29661fb6598be16352103455cc441bc2a1daf5 SHA512 2e699935fb72ddc34aa1f98f5771f252141245ad8fd0983aafe5ea55aeeb3f90b5d68a61c27704adf0b929565180367aae46486d45e789d7de101ec9a7bc9f96
+DIST marco-1.26.0.tar.xz 1855196 BLAKE2B 1481ee365d9bd8430fc5dc11a41268613823ff44c99b0d50a747dfd4663e40f121038a32f148af546f6e500b9a905bb30f6c5c9ff19dedb56eb991e2ceefe95f SHA512 013ba12dc7f4affe24bc5763ae88e44ede3f1454e74b5a642503d3741ce935f6757eba3f9def56670414c5a9c03b38384b5b54a494f9cb8f5bfd480e43300e76
diff --git a/x11-wm/marco/marco-1.26.0.ebuild b/x11-wm/marco/marco-1.26.0.ebuild
new file mode 100644
index 000000000000..2c8046f6b6e4
--- /dev/null
+++ b/x11-wm/marco/marco-1.26.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="FDL-1.2+ GPL-2+ LGPL-2+ MIT"
+SLOT="0/2"
+
+IUSE="startup-notification test xinerama"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ >=gnome-base/libgtop-2:2=
+ media-libs/libcanberra[gtk3]
+ x11-libs/cairo
+ >=x11-libs/pango-1.2[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.3
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpresent
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-libs/startup-notification-0.7
+ xinerama? ( x11-libs/libXinerama )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-extra/zenity
+ >=mate-base/mate-desktop-1.20.0
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.0.0
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+src_install() {
+ mate_src_install
+ dodoc doc/*.txt
+}