summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-06-14 21:01:14 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-09 11:53:19 +0200
commitf21bbf4de7231160807b8db5af75662dae3d740a (patch)
tree90b333208192ba024d9ee4a6c584265c68cbf6b4 /x11-terms
parentx11-terms/gnome-terminal: Bump to 3.52.2 (diff)
downloadgentoo-f21bbf4de7231160807b8db5af75662dae3d740a.tar.gz
gentoo-f21bbf4de7231160807b8db5af75662dae3d740a.tar.bz2
gentoo-f21bbf4de7231160807b8db5af75662dae3d740a.zip
x11-terms/ptyxis: New package 46.5
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34844 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/ptyxis/Manifest1
-rw-r--r--x11-terms/ptyxis/metadata.xml11
-rw-r--r--x11-terms/ptyxis/ptyxis-46.5.ebuild53
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-terms/ptyxis/Manifest b/x11-terms/ptyxis/Manifest
new file mode 100644
index 000000000000..e595aced6717
--- /dev/null
+++ b/x11-terms/ptyxis/Manifest
@@ -0,0 +1 @@
+DIST ptyxis-46.5.tar.xz 3866528 BLAKE2B 784085167461ceeb737005b506e43d1a3fb96f04a501a694a002eee2d17457bfd06e23ad7c8fcec6c5f746f5d07e06e9559ec35e65f7de3942e9dd239bf6fcac SHA512 d66f67ea0bba5a6c449faae75f2bcc0c20254a59cf7ae27f7c67fc11008593d7a3a5cb8ff445b46925e9b6e5aab5f72d4aeee80b9053b0682d6ae1708df02dac
diff --git a/x11-terms/ptyxis/metadata.xml b/x11-terms/ptyxis/metadata.xml
new file mode 100644
index 000000000000..436a7a9f3f66
--- /dev/null
+++ b/x11-terms/ptyxis/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">chergert/ptyxis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-terms/ptyxis/ptyxis-46.5.ebuild b/x11-terms/ptyxis/ptyxis-46.5.ebuild
new file mode 100644
index 000000000000..94be6d392082
--- /dev/null
+++ b/x11-terms/ptyxis/ptyxis-46.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Ptyxis is a terminal for GNOME with first-class support for containers."
+HOMEPAGE="https://gitlab.gnome.org/chergert/ptyxis"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.12.2:4
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=gui-libs/vte-0.75.0:2.91-gtk4[-vanilla]
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevelopment=false
+ -Dgeneric=terminal
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}