summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-09 10:20:06 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-09 10:34:51 +0200
commit026a5f4d039d2a30d4d39948f02bff01ba3b1c92 (patch)
tree53b899ea92501c6a64a42746d4e7787d6e751c8b /www-plugins
parentnet-fs/cifs-utils: Fix krb5 support (diff)
downloadgentoo-026a5f4d039d2a30d4d39948f02bff01ba3b1c92.tar.gz
gentoo-026a5f4d039d2a30d4d39948f02bff01ba3b1c92.tar.bz2
gentoo-026a5f4d039d2a30d4d39948f02bff01ba3b1c92.zip
www-plugins/adobe-flash: Install manifest.json properly (bug #593260 by Ortwin Glueck).
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/adobe-flash-22.0.0.209-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/adobe-flash-22.0.0.209-r1.ebuild b/www-plugins/adobe-flash/adobe-flash-22.0.0.209-r1.ebuild
new file mode 100644
index 000000000000..da08d5d31503
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-22.0.0.209-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ http://www.adobe.com/products/flashplayer.html
+ http://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc"
+AF_32_URI="${AF_URI}/${PV}/flash_player_ppapi_linux.i386.tar.gz -> ${P}.i386.tar.gz"
+AF_64_URI="${AF_URI}/${PV}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}.x86_64.tar.gz"
+
+SRC_URI="
+ abi_x86_32? ( ${AF_32_URI} )
+ abi_x86_64? ( ${AF_64_URI} )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash]
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ exeinto /usr/$(get_libdir)/chromium-browser/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium-browser/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+}