summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-11 03:57:51 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-11 03:57:51 -0800
commit48cd1cdb11e276b155da253f4d56d5f0d79ada3c (patch)
tree1385025a78330feb5068ec7b0a722c00e114b7f3 /sys-apps/opal-utils
parentsys-apps/opal-utils: stabilize 7.0 for ppc64 (diff)
downloadgentoo-48cd1cdb11e276b155da253f4d56d5f0d79ada3c.tar.gz
gentoo-48cd1cdb11e276b155da253f4d56d5f0d79ada3c.tar.bz2
gentoo-48cd1cdb11e276b155da253f4d56d5f0d79ada3c.zip
sys-apps/opal-utils: drop 6.8
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/opal-utils')
-rw-r--r--sys-apps/opal-utils/Manifest1
-rw-r--r--sys-apps/opal-utils/opal-utils-6.8.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/sys-apps/opal-utils/Manifest b/sys-apps/opal-utils/Manifest
index 72dec2bddbcc..9e82638e0a77 100644
--- a/sys-apps/opal-utils/Manifest
+++ b/sys-apps/opal-utils/Manifest
@@ -1,2 +1 @@
-DIST opal-utils-6.8.tar.gz 5321377 BLAKE2B 3be812618dcbd3d877576e1dec0b6a74ad9091b59760bd8f1f67ba9a8efbce79cba4130464dcb6f2b8e61dedca3a1a60103f36d04fcd234b5a4c577c6e07635b SHA512 a799112c14abdcdb37e1a4c63e48e12bb7a67b6c90476d4e60597f06fd6050a58ffd25859cf6bb12c393522e4b4771ce3aa25a1277bac35855d599e9eb357814
DIST opal-utils-7.0.tar.gz 5418069 BLAKE2B 86ad4c1a3000753b0bd48f0cf50e9a91eeff8c2a420a6339e4359a5ce6a35954120d7fe7caff64def83bb06e96c602d099fb1fc8e5b580adb67c48a09fb9d7a8 SHA512 72198f0d1bb0d09cb74fe4656421a73ec1a604ec6fa0965bd82e56819a2d41a1a6588f8a8cc7eb507d73ef401f8557901a5305c844fbfc9f27534c7b2e2e9db3
diff --git a/sys-apps/opal-utils/opal-utils-6.8.ebuild b/sys-apps/opal-utils/opal-utils-6.8.ebuild
deleted file mode 100644
index 458c60157ef3..000000000000
--- a/sys-apps/opal-utils/opal-utils-6.8.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit linux-info python-single-r1 systemd toolchain-funcs
-
-DESCRIPTION="OPAL firmware utilities"
-HOMEPAGE="https://github.com/open-power/skiboot"
-SRC_URI="https://github.com/open-power/skiboot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2+"
-SLOT="0"
-KEYWORDS="ppc64"
-IUSE="doc"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND=""
-RDEPEND="${DEPEND} ${PYTHON_DEPS}"
-
-BDEPEND="doc? ( $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]')
-)"
-
-CONFIG_CHECK="~MTD_POWERNV_FLASH ~OPAL_PRD ~PPC_DT_CPU_FTRS ~SCOM_DEBUGFS"
-ERROR_MTD_POWERND_FLASH="CONFIG_MTD_POWERND_FLASH is required to use pflash and opal-gard"
-ERROR_OPAL_PRD="CONFIG_OPAL_PRD is required to run opal-prd daemon"
-ERROR_SCOM_DEBUGFS="CONFIG_SCOM_DEBUGFS is required to use xscom-utils"
-
-S="${WORKDIR}/skiboot-${PV}"
-
-PATCHES=(
- "${FILESDIR}/flags.patch"
-)
-
-pkg_setup() {
- linux-info_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- tc-export CC LD
- export OPAL_PRD_VERSION="${PV}"
- export GARD_VERSION="${PV}"
- export PFLASH_VERSION="${PV}"
- export XSCOM_VERSION="${PV}"
- export FFSPART_VERSION="${PV}"
-}
-
-src_compile() {
- emake V=1 -C external/opal-prd
- emake V=1 -C external/gard
- emake V=1 -C external/pflash
- emake V=1 -C external/xscom-utils
- emake V=1 -C external/ffspart
-
- use doc && emake V=1 -C doc html
-}
-
-src_install() {
- emake -C external/opal-prd DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/gard DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/pflash DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/xscom-utils DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- dosbin external/ffspart/ffspart
-
- python_domodule external/pci-scripts/ppc.py
- python_doscript external/pci-scripts/phberr.py
-
- newinitd "${FILESDIR}"/opal-prd.initd opal-prd
- newconfd "${FILESDIR}"/opal-prd.confd opal-prd
-
- systemd_dounit external/opal-prd/opal-prd.service
-
- if use doc; then
- rm -r doc/_build/html/_sources || die
- local HTML_DOCS=( doc/_build/html/. )
- fi
- einstalldocs
-}
-
-src_test() {
- emake V=1 -C external/opal-prd test
- emake V=1 -C external/gard check
- # this test is fragile and fails because of filename path
- rm external/pflash/test/tests/01-info || die
- emake V=1 -C external/pflash check
- emake V=1 -C external/ffspart check
-}