summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-09-08 12:47:51 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-09-08 12:47:51 +0700
commitd6fed8734eddc1c87e78a0b13cd994f4f7e394d6 (patch)
tree8f7235b94f376259c44fec4f9c3793e6273756d0 /sci-geosciences/qmapshack
parentdev-python/bottle: Bump to 0.13.1 (diff)
downloadgentoo-d6fed8734eddc1c87e78a0b13cd994f4f7e394d6.tar.gz
gentoo-d6fed8734eddc1c87e78a0b13cd994f4f7e394d6.tar.bz2
gentoo-d6fed8734eddc1c87e78a0b13cd994f4f7e394d6.zip
sci-geosciences/qmapshack: An experimental Qt6 port
Translations and the help system are broken Bug: https://bugs.gentoo.org/926676 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/qmapshack')
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.17.1_p600.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index 14aa90976ed8..986bf4932766 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1 +1,2 @@
DIST qmapshack-1.17.1.tar.gz 56704889 BLAKE2B 1fda3f9874f39eb6b7a0c71ac7b681ebc0f6ea7ae2eefae2b6de4d780556fc5aee45aff230bebcf6ba025959beccffe14a59002fd9552b339892956d2fdd5c50 SHA512 79bdeb59e366cefb2d2a6c9bd084760b5935c93f385a6f2d26bdd25bb4af6939003decc4659afd1567a3b6698a0048e5c79baa716139fc20a96cc0e8dc206d9c
+DIST qmapshack-1.17.1_p600.tar.gz 56720384 BLAKE2B 0a76b90273838898c74d6fcf81de0903cd24c294e5ccb7333cdc478b22f01bb771bcc155683c27e0310b018b2c47cf23235b3cd65b81779f97104e389b79450b SHA512 05729eddaca0fd845490eb56e0a0c4ed6d3a721433c24c3e8a6a424a2d6dbb6f9a16dfc8babe4a4ae1b48d8215f586654b1385f748ee8497d629ecdbe4fae2f9
diff --git a/sci-geosciences/qmapshack/qmapshack-1.17.1_p600.ebuild b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600.ebuild
new file mode 100644
index 000000000000..e35048395d1a
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+COMMIT="1f009ac0be1d1c2a4c31aa1283f4009e88685d34"
+SRC_URI="https://github.com/kiozen/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-db/sqlite
+ dev-libs/quazip:0=[qt6(+)]
+ dev-qt/qt5compat:6[icu,qml]
+ dev-qt/qttools:6[assistant,linguist,opengl,qdbus,qml,widgets,zstd]
+ dev-qt/qtwebengine:6[widgets]
+ sci-geosciences/routino
+ sci-libs/alglib
+ sci-libs/gdal:=
+ sci-libs/proj:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+ ewarn "An experimental Qt6 port"
+ ewarn "Translations and the help system are broken"
+ ewarn "Other bugs to https://github.com/Maproom/qmapshack/issues"
+}