summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/linsmith
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/Manifest1
-rw-r--r--sci-electronics/linsmith/files/linsmith-datafiles.patch30
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.28.ebuild66
-rw-r--r--sci-electronics/linsmith/metadata.xml12
4 files changed, 109 insertions, 0 deletions
diff --git a/sci-electronics/linsmith/Manifest b/sci-electronics/linsmith/Manifest
new file mode 100644
index 000000000000..343b1a8e3813
--- /dev/null
+++ b/sci-electronics/linsmith/Manifest
@@ -0,0 +1 @@
+DIST linsmith-0.99.28.tar.gz 1132315 SHA256 22196edb6e4c72a45a3d0a794a0bb140ab5932a5e59a40e2e9ee143b53c4235d SHA512 0e8811b64703884dc44e0d8c6a6eeefbb3ba65d8af7573a87e1985e9061d3d947f5e35631dbca2444a9ef2600b523358d6b65089ae746312f9e3397a9dd99118 WHIRLPOOL 41416593eb0eb8913bbd1b9d4cc104830f18eb0835b5c262e8725f3a45162a012167d396205dfc362b9908ed35a7643540dc4fe055772c8806d7c02743746dcb
diff --git a/sci-electronics/linsmith/files/linsmith-datafiles.patch b/sci-electronics/linsmith/files/linsmith-datafiles.patch
new file mode 100644
index 000000000000..cae7a2a7c28e
--- /dev/null
+++ b/sci-electronics/linsmith/files/linsmith-datafiles.patch
@@ -0,0 +1,30 @@
+--- Makefile.am.old 2005-11-03 00:56:51.000000000 -0300
++++ Makefile.am 2005-11-03 00:57:09.000000000 -0300
+@@ -20,15 +20,6 @@
+ fi \
+ done \
+ fi
+- @$(NORMAL_INSTALL)
+- if test -d $(srcdir)/datafiles; then \
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/$(PACKAGE); \
+- for datafile in $(srcdir)/datafiles/*; do \
+- if test -f $$datafile; then \
+- $(INSTALL_DATA) $$datafile $(DESTDIR)$(datadir)/$(PACKAGE); \
+- fi \
+- done \
+- fi
+
+ dist-hook:
+ if test -d pixmaps; then \
+@@ -39,11 +30,3 @@
+ fi \
+ done \
+ fi
+- if test -d datafiles; then \
+- mkdir $(distdir)/datafiles; \
+- for datafile in datafiles/*; do \
+- if test -f $$datafile; then \
+- cp -p $$datafile $(distdir)/datafiles; \
+- fi \
+- done \
+- fi
diff --git a/sci-electronics/linsmith/linsmith-0.99.28.ebuild b/sci-electronics/linsmith/linsmith-0.99.28.ebuild
new file mode 100644
index 000000000000..40d8ce21443b
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.28.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use"
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+ doman doc/${PN}.1
+
+ domenu ${PN}.desktop
+ doicon ${PN}_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}
diff --git a/sci-electronics/linsmith/metadata.xml b/sci-electronics/linsmith/metadata.xml
new file mode 100644
index 000000000000..5604ed5d092d
--- /dev/null
+++ b/sci-electronics/linsmith/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">linsmith</remote-id>
+ </upstream>
+</pkgmetadata>