summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-09-29 11:05:32 +0100
committerMatthew Smith <matthew@gentoo.org>2023-09-29 11:05:45 +0100
commita66feb7ae19e2b706986fdc38584c391ced8e4b8 (patch)
treef8ddf9ed00e68789a27afa4c4ceb1484838ce840 /net-mail
parentnet-analyzer/munin: add missing Date::Manip dependency (diff)
downloadgentoo-a66feb7ae19e2b706986fdc38584c391ced8e4b8.tar.gz
gentoo-a66feb7ae19e2b706986fdc38584c391ced8e4b8.tar.bz2
gentoo-a66feb7ae19e2b706986fdc38584c391ced8e4b8.zip
net-mail/mu: drop 1.10.3, 1.10.4
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest2
-rw-r--r--net-mail/mu/mu-1.10.3.ebuild88
-rw-r--r--net-mail/mu/mu-1.10.4.ebuild88
3 files changed, 0 insertions, 178 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 3e2cd648700a..f163ba33b196 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1 @@
-DIST mu-1.10.3.tar.xz 569740 BLAKE2B bfd332d77a0c8727beeac363c35199dd8da0b4dde940981845865eda7e0ff7a7bfcbfef76509ca407bea80b4b148b0b6bce79fa928b2c4df239b55325336c049 SHA512 dbc3946b50791bb01e640d7c07a5072c4c6381b576337899c32b0f0c8331b44ab328f3887eacfff4d5ec71144164a43dc2c1241330bf00226748485027e7f21b
-DIST mu-1.10.4.tar.xz 570024 BLAKE2B 81d0ea6ac018a24eaa9f80e21fdbd6f4e67faba1cf3d6f93721ac32caf1f820b03adfbee096229da95caf229f7dc3c8e78008654296fb684fdc62e0cffab590d SHA512 7c58ddf65c4aaa555d38c3a10ecf5d6e170ff2914515f8f1242ca59226bda09057bcbff2bc5459b448c34c3bd3add9546fd71387891f8eef8b2ee9aa738982e1
DIST mu-1.10.6.tar.xz 570660 BLAKE2B 96816753a3b38392e7e943d8b72fd98b44d201c022b6018eb692cf594bd9f7285a84d00da53ab85a671d5375b7eafb9eb5a0e1fff51ad5a9b2d035fa1c0f8d23 SHA512 78eb5e21ac2dc2a6665a257593781c3b9a390644f78945ce9eef18acab6ca750b16773de2665a1ced9b2f9434b4a2879d07bc586b3abdb82ccc0cd3b59ab51e5
diff --git a/net-mail/mu/mu-1.10.3.ebuild b/net-mail/mu/mu-1.10.3.ebuild
deleted file mode 100644
index 6db9039141c9..000000000000
--- a/net-mail/mu/mu-1.10.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common meson
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
-SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~riscv x86 ~x64-macos"
-IUSE="emacs readline"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gmime:3.0
- >=dev-libs/xapian-1.4:=
- emacs? ( >=app-editors/emacs-25.3:* )
- readline? ( sys-libs/readline:= )"
-RDEPEND="${DEPEND}"
-BDEPEND="
- sys-apps/texinfo
- virtual/pkgconfig
-"
-
-SITEFILE="70mu-gentoo-autoload.el"
-
-src_prepare() {
- default
-
- # Don't install NEWS.org into /usr/share/doc.
- sed -i '/NEWS.org/,+1 d' meson.build || die
- sed -i '/mu4e-about.org/d' mu4e/meson.build || die
-
- # Don't compress the info file.
- sed -i '/gzip/d' build-aux/meson-install-info.sh || die
-
- # Instead, put it in /usr/share/doc/${PF}.
- sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature readline)
- -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
- # TODO: revisit this, it's not actually deprecated, just been reworked
- -Dguile=disabled
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # Since meson no longer installs NEWS.org, install it with dodoc.
- # Also, it must be uncompressed so that it can be viewed with
- # mu4e-info.
- docompress -x /usr/share/doc/${PF}/NEWS.org
- dodoc NEWS.org
-
- # Same as above.
- docompress -x /usr/share/doc/${PF}/mu4e-about.org
- dodoc mu4e/mu4e-about.org
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "After upgrading from an old major version, you should"
- elog "rebuild your mail index."
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
-
- elisp-site-regen
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/mu/mu-1.10.4.ebuild b/net-mail/mu/mu-1.10.4.ebuild
deleted file mode 100644
index 2acec2e5ddb5..000000000000
--- a/net-mail/mu/mu-1.10.4.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common meson
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
-SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
-IUSE="emacs readline"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gmime:3.0
- >=dev-libs/xapian-1.4:=
- emacs? ( >=app-editors/emacs-25.3:* )
- readline? ( sys-libs/readline:= )"
-RDEPEND="${DEPEND}"
-BDEPEND="
- sys-apps/texinfo
- virtual/pkgconfig
-"
-
-SITEFILE="70mu-gentoo-autoload.el"
-
-src_prepare() {
- default
-
- # Don't install NEWS.org into /usr/share/doc.
- sed -i '/NEWS.org/,+1 d' meson.build || die
- sed -i '/mu4e-about.org/d' mu4e/meson.build || die
-
- # Don't compress the info file.
- sed -i '/gzip/d' build-aux/meson-install-info.sh || die
-
- # Instead, put it in /usr/share/doc/${PF}.
- sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature readline)
- -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
- # TODO: revisit this, it's not actually deprecated, just been reworked
- -Dguile=disabled
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # Since meson no longer installs NEWS.org, install it with dodoc.
- # Also, it must be uncompressed so that it can be viewed with
- # mu4e-info.
- docompress -x /usr/share/doc/${PF}/NEWS.org
- dodoc NEWS.org
-
- # Same as above.
- docompress -x /usr/share/doc/${PF}/mu4e-about.org
- dodoc mu4e/mu4e-about.org
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "After upgrading from an old major version, you should"
- elog "rebuild your mail index."
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
-
- elisp-site-regen
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}