summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-firewall/itval
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-firewall/itval')
-rw-r--r--net-firewall/itval/Manifest1
-rw-r--r--net-firewall/itval/files/itval-1.1-gcc44.patch28
-rw-r--r--net-firewall/itval/itval-1.2_p20121104.ebuild37
-rw-r--r--net-firewall/itval/metadata.xml5
4 files changed, 71 insertions, 0 deletions
diff --git a/net-firewall/itval/Manifest b/net-firewall/itval/Manifest
new file mode 100644
index 000000000000..b1343e53b77c
--- /dev/null
+++ b/net-firewall/itval/Manifest
@@ -0,0 +1 @@
+DIST ITVal-20121104.tar.bz2 71398 SHA256 dba3bcd2876b28fad4baedfd39a4d8ddd658d128e50c6f53253d321a082dcf42 SHA512 145f464154d0c88e6c43a16a6ea59f3f6f525612c99032bd5acb934975d46568a40b25996a92d63d190afbe2f129010fb7cdb843dced9eae4ec925b97ee17eca WHIRLPOOL 6c4ebb99b496988749559e83d6170e2f7c211cb9afe7e079a2591f11e01fc679dee5e94b030291bc76995f760b1ad3f056a5a64b110757f93e9d3e3cdbe8bdd2
diff --git a/net-firewall/itval/files/itval-1.1-gcc44.patch b/net-firewall/itval/files/itval-1.1-gcc44.patch
new file mode 100644
index 000000000000..796b67481796
--- /dev/null
+++ b/net-firewall/itval/files/itval-1.1-gcc44.patch
@@ -0,0 +1,28 @@
+--- a/FDDL/mdd.h
++++ b/FDDL/mdd.h
+@@ -29,10 +29,11 @@
+ //#define BRIEF_DEBUG
+
+ #ifndef FDDL_MDD_H
+ # define FDDL_MDD_H 1
+
++# include <cstdio>
+ # include <iostream>
+ # include <assert.h>
+
+ # include <FDDL/mddtypes.h>
+ # include <FDDL/caches.h>
+--- a/src/structures.h
++++ b/src/structures.h
+@@ -28,10 +28,11 @@
+
+ #ifndef __STRUCTURES_H
+ #define __STRUCTURES_H
+
+ #include <stdlib.h>
++#include <cstdio>
+
+ //Linked list of IP addresses
+ class address
+ {
+ public:
diff --git a/net-firewall/itval/itval-1.2_p20121104.ebuild b/net-firewall/itval/itval-1.2_p20121104.ebuild
new file mode 100644
index 000000000000..87c74aa5e6f0
--- /dev/null
+++ b/net-firewall/itval/itval-1.2_p20121104.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils versionator
+
+MY_PN="ITVal"
+MY_PV="$(get_version_component_range 3)"
+MY_PV="${MY_PV/p/}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Iptables policy testing and validation tool"
+HOMEPAGE="http://itval.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-libs/fddl"
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README RELEASE )
+
+src_install() {
+ default
+ doman man/ITVal.n
+}
diff --git a/net-firewall/itval/metadata.xml b/net-firewall/itval/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-firewall/itval/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>