summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2022-01-28 22:38:29 -0800
committerJoonas Niilola <juippis@gentoo.org>2022-02-27 16:10:30 +0200
commit8aed6972f97e38ddfb718ca8fcaedc8f20a0a4eb (patch)
tree40810310cd51242f3bdcd3766a8cbe5f22c0d640 /media-sound/lollypop
parentmedia-sound/lollypop: Correct LICENSE to GPL-3+ (diff)
downloadgentoo-8aed6972f97e38ddfb718ca8fcaedc8f20a0a4eb.tar.gz
gentoo-8aed6972f97e38ddfb718ca8fcaedc8f20a0a4eb.tar.bz2
gentoo-8aed6972f97e38ddfb718ca8fcaedc8f20a0a4eb.zip
media-sound/lollypop: Add 1.4.29, Python 3.10 and test; clean up deps
Bug: https://bugs.gentoo.org/750872 Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24008 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.4.29.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index d80dd4dba886..1519f09b3bd6 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.2.35.tar.xz 509916 BLAKE2B 8cf9ea74287b6ac7d4942c2312cc4d6e07d4748d505cc9e45a896129f9e4a43ef5c65c0c18764597d7ce3c4d2fc93804c501f68ea3b67625e200497613077af6 SHA512 179fa5e77482db35de9e30e392e6d07bb5c832d5d1decaee06982570bdcbb809dc99375eeb6fe3dce75829af3570953ce517e3b4eaabceac807b9d5c382bd53e
DIST lollypop-1.4.18.tar.xz 575120 BLAKE2B 62ff404c0e7c2ac7029ebb45143db35b0b93b30bfc386fb08aa4a2fc10916efb190118f41e40a0f795bef4f8d0b21b0353b9e27bbb75c5471132145028fc8b27 SHA512 17f2db91a56fd140c66c251732eca4b2a6cc1849b5dc72f0a4014c766c64eee475bc9d2305d307e2a54184ab5dd812a5fb27b39acf60a1c468770d1d34307982
+DIST lollypop-1.4.29.tar.xz 593980 BLAKE2B 8a3a985cb18c196665377c7c29670b98f352a86284ee8bb5af13b1017346b0b2b938dee6e53d56d0b8d98b191a64e5efd1c7126879c7017c3f10d5aa96570a39 SHA512 f81315a94cbcc726cd453d58faffe5c33ebcbdaef55a5a36d2a9dc20dec9340c2d263d935b5115148b049fca52e57c88eac36386e56f0965f22674eba26ae813
diff --git a/media-sound/lollypop/lollypop-1.4.29.ebuild b/media-sound/lollypop/lollypop-1.4.29.ebuild
new file mode 100644
index 000000000000..c123937bb8ea
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.29.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}