summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-17 13:34:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-17 13:36:05 +0200
commit2680ca104e87960cf12a520a3723c600c30bfcc8 (patch)
tree8a75f54cdd34af9680361fd2025e92764c43d3b0 /media-sound/bluez-alsa
parentdev-perl/Gtk3-SimpleList: amd64 stable wrt bug #694976 (diff)
downloadgentoo-2680ca104e87960cf12a520a3723c600c30bfcc8.tar.gz
gentoo-2680ca104e87960cf12a520a3723c600c30bfcc8.tar.bz2
gentoo-2680ca104e87960cf12a520a3723c600c30bfcc8.zip
media-sound/bluez-alsa: Bump to version 2.0.0
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/bluez-alsa')
-rw-r--r--media-sound/bluez-alsa/Manifest1
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-2.0.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/bluez-alsa/Manifest b/media-sound/bluez-alsa/Manifest
index 65879095741e..1d7bdf4c4a45 100644
--- a/media-sound/bluez-alsa/Manifest
+++ b/media-sound/bluez-alsa/Manifest
@@ -1,2 +1,3 @@
DIST bluez-alsa-1.3.1.tar.gz 87333 BLAKE2B 0479baa103b9e6e5c26d061df59b0a36a24a74ee04c882a888d63458da96a980bc9f39a6219cd4ad9f8c04b0d58fb337a960584eb7b93455474111a71ddbeb9f SHA512 2b2f7b26b7b8cff70517bf8a24170330038be40f1a5a2fc75d20853b7beca6c9f9e2e6068f6b0f4fa9b6fc61f374ff59961434be8daa3b4d283abfd165be9cbf
DIST bluez-alsa-1.4.0.tar.gz 102539 BLAKE2B 8e640ba5c0cadfa5478885dc6affef790bd50fe04821602156a598082efc8733f0917a91240af7881f980e89ec0e36801e537feedec3ce357087b040f852eeb0 SHA512 fa4ad21c7b9ac200cdc7628bf0276bbb0beac94066a6c5e69c47a5286f6e13a7dc61caab23acbb14a37c2b97894c425052a09adb8f967038f6fd99557208629f
+DIST bluez-alsa-2.0.0.tar.gz 116895 BLAKE2B 97dfd3364259e8a633de0259c84efe4dc4a80a9f388620200c44136844af6f3e101bf6d49931e1b5cd466d4b1ff13b2a7b9284d4599db72039ee3c5afa5800ba SHA512 21152be594421cd00056e94065dcf767ca01f7b040117974315f97aab45db020264e33dabddac7fee12834a4ada9073b9ff680c25d8775b47604cb0bec638a7b
diff --git a/media-sound/bluez-alsa/bluez-alsa-2.0.0.ebuild b/media-sound/bluez-alsa/bluez-alsa-2.0.0.ebuild
new file mode 100644
index 000000000000..0e5b0d27ae84
--- /dev/null
+++ b/media-sound/bluez-alsa/bluez-alsa-2.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib-minimal systemd
+
+DESCRIPTION="Bluetooth Audio ALSA Backend"
+HOMEPAGE="https://github.com/Arkq/bluez-alsa"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arkq/${PN}"
+else
+ SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="aac debug hcitop ldac ofono static-libs test"
+
+RDEPEND=">=dev-libs/glib-2.26[dbus,${MULTILIB_USEDEP}]
+ >=media-libs/alsa-lib-1.1.2[${MULTILIB_USEDEP}]
+ >=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
+ >=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
+ sys-libs/readline:0=
+ aac? ( >=media-libs/fdk-aac-0.1.1:=[${MULTILIB_USEDEP}] )
+ hcitop? (
+ dev-libs/libbsd
+ sys-libs/ncurses:0=
+ )
+ ldac? ( >=media-libs/libldac-2.0.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-rfcomm
+ $(use_enable aac)
+ $(use_enable debug)
+ $(use_enable ofono)
+ $(use_enable static-libs static)
+ $(use_enable test)
+ $(multilib_native_use_enable hcitop)
+ $(multilib_native_use_enable ldac)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+
+ newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
+ systemd_dounit "${FILESDIR}"/bluealsa.service
+}
+
+pkg_postinst() {
+ elog "Users can use this service when they are members of the \"audio\" group."
+}