summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-23 19:32:30 -0700
committerYixun Lan <dlan@gentoo.org>2024-07-25 00:01:09 +0000
commit2ee6449501cf06a49ac91990eebc8251845dd624 (patch)
tree67bf69edf687ca03f46d8940d5b27ed80282ec45 /gui-libs/aquamarine
parentgui-libs/aquamarine: new package, add 9999 (diff)
downloadgentoo-2ee6449501cf06a49ac91990eebc8251845dd624.tar.gz
gentoo-2ee6449501cf06a49ac91990eebc8251845dd624.tar.bz2
gentoo-2ee6449501cf06a49ac91990eebc8251845dd624.zip
gui-libs/aquamarine: add 0.1.1
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs/aquamarine')
-rw-r--r--gui-libs/aquamarine/Manifest1
-rw-r--r--gui-libs/aquamarine/aquamarine-0.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/Manifest b/gui-libs/aquamarine/Manifest
new file mode 100644
index 000000000000..f3b2ca57f389
--- /dev/null
+++ b/gui-libs/aquamarine/Manifest
@@ -0,0 +1 @@
+DIST aquamarine-0.1.1.tar.gz 70241 BLAKE2B 511e03fed61f970b6309f4cc630e6cfee9eabb4b2d95da27699aa9b38e8e20922847272c9bb4467fb59f428b7137196be2e31cf4e34ac0bb61df5e1520c6f27a SHA512 5e51db094d8a30b53f6bd0e8895039adb354f04428c49e6d1b6fdbbc13d9e8ee02d42da1f9d78bb495a0cd8e286888323a5dbdf663ae6df7495072ed6ab4abc2
diff --git a/gui-libs/aquamarine/aquamarine-0.1.1.ebuild b/gui-libs/aquamarine/aquamarine-0.1.1.ebuild
new file mode 100644
index 000000000000..80acaec62cc4
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-0.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ gui-libs/egl-gbm
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}