summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-04-22 12:28:54 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 13:24:03 +0200
commitbb1ea36545bdbcc28ef75d4b1de67e5e41036209 (patch)
treef6f0e8cc0bed806721d578708cd380d62c909026 /gnome-extra
parentapp-editors/ghex: update HOMEPAGE (diff)
downloadgentoo-bb1ea36545bdbcc28ef75d4b1de67e5e41036209.tar.gz
gentoo-bb1ea36545bdbcc28ef75d4b1de67e5e41036209.tar.bz2
gentoo-bb1ea36545bdbcc28ef75d4b1de67e5e41036209.zip
gnome-extra/gnome-boxes: Bump to 46.1
Closes: https://bugs.gentoo.org/934419 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36842 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 0aec799390f8..5273542b552a 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1 +1,2 @@
DIST gnome-boxes-45.0.tar.xz 1239116 BLAKE2B 15f52a78cf3a3b010a7ad662d4a7f537e43e7793baf85918abc64d65e260e3e9c7a84dfa0c8b2a37e911363a04b26ae3cb285baa065a9620e145e01478640d5d SHA512 f8e1f5562ef65b05f8f2bb156646ee8bc8c951268386ede175567e8ec6104e1c1ee427d3cef3e6a2be7234bc2a3cfc44c80f55144be2ffbb96778142279ba334
+DIST gnome-boxes-46.1.tar.xz 1249848 BLAKE2B 56776a2bd66923caa777ec0d3f397f5f70352fd1b2108e22223c652ff46c0e579d6adda2ab56968336b9b833bd0846bdbd19404eed89731e986e73b45e5eb728 SHA512 db2ffb3d69c4689d3a318b5ae0fbbb61485b89c093a448715e4536aa5b68d306946b86a08bf75f7bd2eda5aee54df9ca3bd763ae35d446e530ab5326b8cacaf0
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
new file mode 100644
index 000000000000..105f41b65061
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://gnomeboxes.org"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and
+# it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=dev-libs/libportal-0.7[gtk]
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-5.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# - sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# - app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# - app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# - sys-apps/policycoreutils restorecon is used for checking selinux context
+# - app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# - sys-auth/polkit used for making all libvirt system disks readable via "pkexec
+# chmod a+r" that aren't already readable to the user (libvirt system importer)
+# - app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}