summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-21 09:01:41 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-25 11:25:03 -0400
commitf505ca13dfaea811737c759f6fdb1bf2bb5c5632 (patch)
tree696a426a7018de3ae6f43342302e43d1b3c830c1 /gnome-extra/evolution-ews
parentgnome-extra/evolution-data-server: Version bump to 3.46.1 (diff)
downloadgentoo-f505ca13dfaea811737c759f6fdb1bf2bb5c5632.tar.gz
gentoo-f505ca13dfaea811737c759f6fdb1bf2bb5c5632.tar.bz2
gentoo-f505ca13dfaea811737c759f6fdb1bf2bb5c5632.zip
gnome-extra/evolution-ews: Version bump to 3.46.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27875 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.46.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 4699b74ca694..3dbbc62f80e7 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.44.4.tar.xz 691396 BLAKE2B 69344bec9dffe21e54e77325929b791cc89072e9a2a2f9a0fbcf5551c1f8b13c90c4a3c2bd934956c4e1b73b306fbdd6827c6fb4ef7aee182a3bdbeb450d124a SHA512 0326b274fbcc3630ccaf6517495ce22409706f0ad16c11b189f91c27ab8921a639bb07296d51063e71cb706e66bd861044adbf146b16f9fca4b4cd9cde6edb65
DIST evolution-ews-3.46.0.tar.xz 691740 BLAKE2B 1d956a39dc0233c8a8c3a23f2be3be2e2d697eca71d4e7317db69ca4ade007a4e2ac51edb99851aa75c009ed40e5c0b149b1ddab7cd6826eb4dddcb08f62f326 SHA512 3c01e981857e02c45660bd0d8143ce0f19dd20b30916b8334c15546e6ff720efb4fd52ab0cfb312a5767958cf0eceb5e39213256b75feb15e5c1fea6755b2dd9
+DIST evolution-ews-3.46.1.tar.xz 692020 BLAKE2B 9ccabf0393842a829f5a319fcca886e1546cf1bad3e5199683822ef68c9c285430076a11e87f646f052e9e4c8ba691029d31bce4b4da833c6e291252ab0f57fd SHA512 0e258aa2af4305f46926c43dba1787cf5e577567aa385e7d039b2e18d9660e24f7571b9b4e8660a8203e6dabd3f1346670164620f73c9465cbb6516a7076ab25
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.46.1.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.46.1.ebuild
new file mode 100644
index 000000000000..d8248e7b6518
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.46.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}