summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-21 11:26:55 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-21 23:08:05 -0400
commit4ab48773ad69cd3f60c3ef5d6dd557981109f489 (patch)
tree73727ab3c2dd6f9898f0fbba807e9119b2cd8f47 /gnome-extra/evolution-ews
parentgnome-extra/evolution-data-server: Version bump to 3.48.1 (diff)
downloadgentoo-4ab48773ad69cd3f60c3ef5d6dd557981109f489.tar.gz
gentoo-4ab48773ad69cd3f60c3ef5d6dd557981109f489.tar.bz2
gentoo-4ab48773ad69cd3f60c3ef5d6dd557981109f489.zip
gnome-extra/evolution-ews: Version bump to 3.48.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30680 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.48.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 3a9f0dc2ff5f..a360a0ff1ced 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.46.4.tar.xz 695628 BLAKE2B e0504e77059efa80e55b19707ab5aa72b583e05443ede3a1a95ad2f5c46e5e2d11a6b243df3350f4dc875463b99b18075ed4b73f419c35ec2c6f784e76dea723 SHA512 29f6e1c02b332fb2442911550edd4de8fbac93e14ca0c92c9a07410ef8323988733f67afab4935b7ac9e4ca9e704548eed0bb7a71299426d8c7b2e21fc323ea4
DIST evolution-ews-3.48.0.tar.xz 701528 BLAKE2B 0733427443fec5fe3b539d906cdc496d4c8801dd35ba3cb75fe45bbc2c96b15841fa9fe1108417b4aa39e51f4e89e3b83692846206f814f4b17710b0f73f3109 SHA512 c9d54a587682145979681ffa3fc6420596fb706a63f82073536a213c4d545fd35cd08d96881c1ddca7294c400ab064504ba42750bc80c9e7d2dee779fce3fb04
+DIST evolution-ews-3.48.1.tar.xz 701696 BLAKE2B ddce95682a3b4bc75755f9c3e056942c95dfb929bcb40b99d02bf51126897d83f8ef7e68dc6c77af7f82f427dcad4c4e9fb51173b1b22f5d35985a353a1b2040 SHA512 b6166f2dd10c2b5b9ca0e5d5dde0c32ca7082f1c594e8b59642b943870dc5343f1ec4d07a7563c33a1252e989ec1e9ff360f98caf0b590a21dfec42383893a45
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.48.1.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.48.1.ebuild
new file mode 100644
index 000000000000..675ec4ff7d00
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.48.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}