summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 17:13:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 18:30:29 +0200
commite33053f4098c027323c7d0b3bf61ed8acfd95804 (patch)
treeeb9437e835647a4f47d537ef34083edab4ee000e /games-strategy
parentgames-fps/worldofpadman: update upstream metadata (diff)
downloadgentoo-e33053f4098c027323c7d0b3bf61ed8acfd95804.tar.gz
gentoo-e33053f4098c027323c7d0b3bf61ed8acfd95804.tar.bz2
gentoo-e33053f4098c027323c7d0b3bf61ed8acfd95804.zip
games-strategy/freeciv: Fix build w/ USE=qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/files/freeciv-3.1.0-qt6.patch24
-rw-r--r--games-strategy/freeciv/freeciv-3.1.0.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/games-strategy/freeciv/files/freeciv-3.1.0-qt6.patch b/games-strategy/freeciv/files/freeciv-3.1.0-qt6.patch
new file mode 100644
index 000000000000..9aa363a11e02
--- /dev/null
+++ b/games-strategy/freeciv/files/freeciv-3.1.0-qt6.patch
@@ -0,0 +1,24 @@
+From 8da1d4c91dff53db6d903730855ed6a02252e53d Mon Sep 17 00:00:00 2001
+From: Marko Lindqvist <cazfi74@gmail.com>
+Date: Wed, 17 Apr 2024 07:02:20 +0300
+Subject: [PATCH] Qt: Add Q_OBJECT for fc_shortcut_popup
+
+See RM #462
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+---
+ client/gui-qt/shortcuts.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/client/gui-qt/shortcuts.h b/client/gui-qt/shortcuts.h
+index 7574ce4f8e..9d02d1c3f6 100644
+--- a/client/gui-qt/shortcuts.h
++++ b/client/gui-qt/shortcuts.h
+@@ -155,6 +155,7 @@ class line_edit : public QLineEdit
+ **************************************************************************/
+ class fc_shortcut_popup : public QDialog
+ {
++ Q_OBJECT
+ public:
+ fc_shortcut_popup(QWidget *parent);
+ void run(fc_shortcut *s);
diff --git a/games-strategy/freeciv/freeciv-3.1.0.ebuild b/games-strategy/freeciv/freeciv-3.1.0.ebuild
index 0b5e2c809016..17f914cff915 100644
--- a/games-strategy/freeciv/freeciv-3.1.0.ebuild
+++ b/games-strategy/freeciv/freeciv-3.1.0.ebuild
@@ -92,6 +92,7 @@ pkg_setup() {
PATCHES=(
"${FILESDIR}"/${PN}-3.1.0_beta4-fix-manpage-install-location.patch
+ "${FILESDIR}"/${P}-qt6.patch # from git master
)
src_prepare() {