summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-06 12:30:49 +0100
committerSam James <sam@gentoo.org>2024-08-06 12:30:49 +0100
commit79fab52ed6f9b7e0d07529460ef05ed338c45efa (patch)
treec2faddcc8f55fca722c090ef134eb13fa0c8e30d /games-strategy
parentmedia-libs/webrtc-audio-processing: fix build w/ gcc-15 (diff)
downloadgentoo-79fab52ed6f9b7e0d07529460ef05ed338c45efa.tar.gz
gentoo-79fab52ed6f9b7e0d07529460ef05ed338c45efa.tar.bz2
gentoo-79fab52ed6f9b7e0d07529460ef05ed338c45efa.zip
games-strategy/warzone2100: fix build w/ gcc-15
Not sent upstream as we should really bump warzone2100 first. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/files/warzone2100-4.4.2-gcc15-cstdint.patch30
-rw-r--r--games-strategy/warzone2100/warzone2100-4.4.2.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/games-strategy/warzone2100/files/warzone2100-4.4.2-gcc15-cstdint.patch b/games-strategy/warzone2100/files/warzone2100-4.4.2-gcc15-cstdint.patch
new file mode 100644
index 000000000000..75e1aaeb97a0
--- /dev/null
+++ b/games-strategy/warzone2100/files/warzone2100-4.4.2-gcc15-cstdint.patch
@@ -0,0 +1,30 @@
+--- a/3rdparty/SQLiteCpp/include/SQLiteCpp/Statement.h
++++ b/3rdparty/SQLiteCpp/include/SQLiteCpp/Statement.h
+@@ -14,6 +14,7 @@
+ #include <SQLiteCpp/Exception.h>
+ #include <SQLiteCpp/Utils.h> // SQLITECPP_PURE_FUNC
+
++#include <cstdint>
+ #include <string>
+ #include <map>
+ #include <memory>
+--- a/lib/wzmaplib/include/wzmaplib/map_io.h
++++ b/lib/wzmaplib/include/wzmaplib/map_io.h
+@@ -21,6 +21,7 @@
+ #pragma once
+
+ #include <cstddef>
++#include <cstdint>
+ #include <string>
+ #include <memory>
+ #include <vector>
+--- a/lib/wzmaplib/src/map_script.h
++++ b/lib/wzmaplib/src/map_script.h
+@@ -19,6 +19,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <vector>
+ #include <string>
+ #include <memory>
diff --git a/games-strategy/warzone2100/warzone2100-4.4.2.ebuild b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
index 3125e1492345..1d21880339b4 100644
--- a/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
+++ b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
@@ -65,6 +65,7 @@ DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
PATCHES=(
"${FILESDIR}"/${PN}-4.1.3-no-compress-manpages.patch
+ "${FILESDIR}"/${PN}-4.4.2-gcc15-cstdint.patch
)
src_unpack() {