summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-17 23:00:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-17 23:00:57 +0100
commit5df6b773d01a4622a5e1ed5445349bb4d7a79107 (patch)
tree8c1187077b630dfc131452c0309205b618aee91d /games-puzzle
parentsys-cluster/k9scli: add 0.32.4 (diff)
downloadgentoo-5df6b773d01a4622a5e1ed5445349bb4d7a79107.tar.gz
gentoo-5df6b773d01a4622a5e1ed5445349bb4d7a79107.tar.bz2
gentoo-5df6b773d01a4622a5e1ed5445349bb4d7a79107.zip
games-puzzle/wakkabox: EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild30
-rw-r--r--games-puzzle/wakkabox/wakkabox-1.1.0-r2.ebuild32
2 files changed, 32 insertions, 30 deletions
diff --git a/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild b/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild
deleted file mode 100644
index a04dd8404b70..000000000000
--- a/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools desktop
-
-DESCRIPTION="A simple block-pushing game"
-HOMEPAGE="http://kenn.frap.net/wakkabox/"
-SRC_URI="http://kenn.frap.net/wakkabox/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=media-libs/libsdl-1.0.1"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- eapply "${FILESDIR}"/${P}-gentoo.patch
- rm aclocal.m4
- eautoreconf
-}
-
-src_install() {
- default
- newicon bigblock.bmp ${PN}.bmp
- make_desktop_entry ${PN} "Wakkabox" /usr/share/pixmaps/${PN}.bmp
-}
diff --git a/games-puzzle/wakkabox/wakkabox-1.1.0-r2.ebuild b/games-puzzle/wakkabox/wakkabox-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..ea075d716b7c
--- /dev/null
+++ b/games-puzzle/wakkabox/wakkabox-1.1.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop xdg
+
+DESCRIPTION="A simple block-pushing game"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ rm aclocal.m4 || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon bigblock.bmp ${PN}.bmp
+ make_desktop_entry ${PN} ${PN^} /usr/share/pixmaps/${PN}.bmp
+}