summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-12 09:34:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-12 09:38:25 -0400
commitfe930d29997bc3950e120aaee37074a30734c4f9 (patch)
tree78a11e17f14d12534008a0fd8ae66032633afd29 /games-kids
parentgames-board/pysolfc: add 2.16.0 (diff)
downloadgentoo-fe930d29997bc3950e120aaee37074a30734c4f9.tar.gz
gentoo-fe930d29997bc3950e120aaee37074a30734c4f9.tar.bz2
gentoo-fe930d29997bc3950e120aaee37074a30734c4f9.zip
games-kids/gmult: fix build with meson-0.62.1
Closes: https://bugs.gentoo.org/843866 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/files/gmult-10.0-meson-0.62.patch21
-rw-r--r--games-kids/gmult/gmult-10.0.ebuild4
2 files changed, 25 insertions, 0 deletions
diff --git a/games-kids/gmult/files/gmult-10.0-meson-0.62.patch b/games-kids/gmult/files/gmult-10.0-meson-0.62.patch
new file mode 100644
index 000000000000..a3b12300e292
--- /dev/null
+++ b/games-kids/gmult/files/gmult-10.0-meson-0.62.patch
@@ -0,0 +1,21 @@
+New meson is more picky about using exe in test() that wasn't found.
+https://bugs.gentoo.org/843866
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -41,9 +41,11 @@
+ )
+
+-test(
+- 'validate-appstream',
+- appstream_util,
+- args: ['--nonet', 'validate-relax', gmult_appdata],
+-)
++if appstream_util.found()
++ test(
++ 'validate-appstream',
++ appstream_util,
++ args: ['--nonet', 'validate-relax', gmult_appdata],
++ )
++endif
+
+ resources = gnome.compile_resources(
diff --git a/games-kids/gmult/gmult-10.0.ebuild b/games-kids/gmult/gmult-10.0.ebuild
index 6df28b33de33..7ef500d6f09a 100644
--- a/games-kids/gmult/gmult-10.0.ebuild
+++ b/games-kids/gmult/gmult-10.0.ebuild
@@ -28,6 +28,10 @@ BDEPEND="
DOCS=( NEWS.md README.md )
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-0.62.patch
+)
+
src_configure() {
vala_setup
meson_src_configure