summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-05-13 21:17:37 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-05-14 11:32:29 +0200
commit6c8a26a3043640120b737951648b2b053fd3eca7 (patch)
tree1a5ed6a74784a28be5f0d9a4a31d595d2396f6a9 /dev-util
parentapp-editors/emacs: Add valgrind support (diff)
downloadgentoo-6c8a26a3043640120b737951648b2b053fd3eca7.tar.gz
gentoo-6c8a26a3043640120b737951648b2b053fd3eca7.tar.bz2
gentoo-6c8a26a3043640120b737951648b2b053fd3eca7.zip
dev-util/poke: add 3.2
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/poke/Manifest1
-rw-r--r--dev-util/poke/poke-3.2.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-util/poke/Manifest b/dev-util/poke/Manifest
index 5e153dbaec48..9f2c77817bd0 100644
--- a/dev-util/poke/Manifest
+++ b/dev-util/poke/Manifest
@@ -2,3 +2,4 @@ DIST poke-2.4.tar.gz 7372092 BLAKE2B 64b8b22713bb581c30b624200c0a283a8de548895db
DIST poke-2.90.1.tar.gz 7512925 BLAKE2B 38c9283f1c0b183b1b74c2ebd347edf6e9a9191d19070f7da32e6b0f520ec8197be3a813bc98160b47363cd11069bdaf84bb528498fe51cf2dcadf0bfa06a25e SHA512 f5823bed61ab64c2cdde83c918716fe64ad5552499023b2f5202130d6b2bab405c9d1cb1e12c7f190749689d86bf36f4edfe140ce748ac4c5f03d219197558d3
DIST poke-3.0.tar.gz 7510801 BLAKE2B 4e80bd0603b0f690f7b6dc9b3913bb165f61160cd6e677751e6f8ea444bc395141204cc32c3ed97bad4b4044d505a800a64a4c973200e7338b50f05d9ea90c25 SHA512 5b786cdfae732a1f7196b0c4bf271c97f204f8fe9de9b34d92704f35150c8abfc2c080940d67efac63e3e82d0d4afe2fde4b75066faf9f4d1e9df6b6f62edb96
DIST poke-3.1.tar.gz 7562582 BLAKE2B c348973185e7f33d670a9dccab60c02e8ccc247c5aa46936ac4b04674687c9e7edae707639a16c3853232b422d0c969930fe3879b59c1dba351fe7c3da56d34f SHA512 5680ce13b0a8e9a1f2770d295bccf7ccbe3aff54f3f4301a12c4719f54a6717ce5addb6ae3fe0478d0e426ccc756ef06a5e852b0d6ada0f8d3c587640ad209dd
+DIST poke-3.2.tar.gz 7559660 BLAKE2B c1d5739a1a497fb3daadec53fe812b65ec787dd268030a6517764541497c82451f4df391f3c434ef7729bc8e3762c31852ef3ce41aa83928e7646c40bde557dd SHA512 bd3651a2962165b318cc59c53604199eb6278ee3be45c18c36864612b0926d78a06f0e1338fdcc1fcd1cd48e2792bb3cd36a2bb5383143a66dc3aab023c0019c
diff --git a/dev-util/poke/poke-3.2.ebuild b/dev-util/poke/poke-3.2.ebuild
new file mode 100644
index 000000000000..80e149428e9b
--- /dev/null
+++ b/dev-util/poke/poke-3.2.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common flag-o-matic toolchain-funcs
+
+DESCRIPTION="Extensible editor for structured binary data"
+HOMEPAGE="https://www.jemarch.net/poke"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/poke.git"
+ REGEN_BDEPEND="
+ >=sys-devel/autoconf-2.62
+ >=sys-devel/automake-1.16
+ sys-apps/gawk
+ sys-apps/help2man
+ sys-apps/texinfo
+ sys-devel/bison
+ sys-devel/flex
+ "
+elif [[ $(ver_cut 2) -ge 90 || $(ver_cut 3) -ge 90 ]]; then
+ SRC_URI="https://alpha.gnu.org/gnu/poke/${P}.tar.gz"
+ REGEN_BDEPEND=""
+else
+ SRC_URI="mirror://gnu/poke/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ REGEN_BDEPEND=""
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="emacs pvm-profiling nbd nls test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boehm-gc:=
+ dev-libs/libatomic_ops
+ sys-devel/gettext
+ sys-libs/readline:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ nbd? ( sys-libs/libnbd )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( nbd? ( sys-libs/libnbd[uri-support] ) )
+"
+BDEPEND="
+ ${REGEN_BDEPEND}
+ virtual/pkgconfig
+ pvm-profiling? ( sys-devel/gcc )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ test? (
+ dev-util/dejagnu
+ nbd? ( sys-block/nbdkit )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_pretend() {
+ if use pvm-profiling && ! tc-is-gcc; then
+ die "USE=pvm-profiling requires GCC"
+ fi
+}
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ ./bootstrap || die
+ fi
+}
+
+src_configure() {
+ # See bug 858461.
+ # Upstream support might happen one day. For context, only one file needs
+ # LTO to be disabled (since it's an autogenerated bytecode interpreter),
+ # others do not. The build system will handle this at some point in the
+ # future. Until then, just filter out LTO.
+ filter-lto
+
+ local myconf=(
+ --with-lispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --enable-hserver
+ $(use_enable nbd libnbd)
+ $(use_enable pvm-profiling)
+ $(use_enable nls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ cd etc || die
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ cd etc || die
+ elisp-install "${PN}" *.el *.elc
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}