summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 18:03:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 19:51:37 +0100
commit0150b6c6d62cae0856f65d7c54aaa905e45fb363 (patch)
treea1705e06639f9029ebb1922caf7c500222becb68 /dev-python/python-glanceclient
parentdev-python/python-ironicclient: Bump to 5.1.0 (diff)
downloadgentoo-0150b6c6d62cae0856f65d7c54aaa905e45fb363.tar.gz
gentoo-0150b6c6d62cae0856f65d7c54aaa905e45fb363.tar.bz2
gentoo-0150b6c6d62cae0856f65d7c54aaa905e45fb363.zip
dev-python/python-glanceclient: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 58a0336bd887..f3072f2a6f20 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1 +1,2 @@
DIST python-glanceclient-4.2.0.tar.gz 204378 BLAKE2B ee869971f769dd01da2dcf7e1d7ca07e120b5a2ad5a210db7b6cf813a0bb14bb00f8d7f64a4a5c03de61983abfad0448ff3ad9ab4b9acb485a897ae39e4c9409 SHA512 4977db9650ec35ad663fdaa9c576fb1c63efddb9f3df8a92da9e97e530bb5a63016e2492f81239fbb4d01cf260e673c2d489566c10483d2bf6ff9e0653e3bd21
+DIST python-glanceclient-4.3.0.tar.gz 205005 BLAKE2B 63f99858e4fafd041a99a34e3a0a22403f637d2317fe236fd9da55f84f7bc58b410fe4b859af2cf7ccc8cb4f8cf17f80e57afa846a9f33e9a54b1da069f6a6ea SHA512 7f381a6f997b8d1c73c9d2bafa14ecf3d4899640f28d669b7b4762a9c01d8df366b616f0be9bc00c7ea4561f407adceb8d10e721d12d4f5fb5790fd4cdb7362d
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.3.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.3.0.ebuild
new file mode 100644
index 000000000000..d2a627335580
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}