summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:09:05 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:47:47 +0100
commit206637dabe384e08b4a83e1677654b3ff1baeda9 (patch)
treeff18bf1cc06da5451b2c3d8f0523a2249fc99946 /dev-php/pecl-dbase
parentdev-php/pecl-crack: add PHP 7.4 support (diff)
downloadgentoo-206637dabe384e08b4a83e1677654b3ff1baeda9.tar.gz
gentoo-206637dabe384e08b4a83e1677654b3ff1baeda9.tar.bz2
gentoo-206637dabe384e08b4a83e1677654b3ff1baeda9.zip
dev-php/pecl-dbase: add PHP 7.4 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-dbase')
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
index 0eecaf7babb8..43d998a62c33 100644
--- a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
+++ b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
@@ -5,12 +5,12 @@ EAPI="7"
# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
# This allows us to depend on the other slot
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# However, we only really build for 7.x; so redefine it here
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
KEYWORDS="~amd64 ~x86"
@@ -23,7 +23,7 @@ DEPEND=""
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-dbase:0[php_targets_php5-6] )"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
eapply_user
@@ -31,14 +31,14 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
local PHP_EXT_ECONF_ARGS=( )
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}