summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/adodb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/adodb')
-rw-r--r--dev-php/adodb/Manifest1
-rw-r--r--dev-php/adodb/adodb-5.18.ebuild35
-rw-r--r--dev-php/adodb/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/adodb/Manifest b/dev-php/adodb/Manifest
new file mode 100644
index 000000000000..670aa4bf959d
--- /dev/null
+++ b/dev-php/adodb/Manifest
@@ -0,0 +1 @@
+DIST adodb518a.tgz 544455 SHA256 3814dbd776ec5416f9a03eb4eecb081844b0166240dd539439cf27c79efb4d5e SHA512 d561a5143e903195a2c87e637b33c9767f62148d7466fa6cb84d3bc86e5b303c0bf0f04cf370db4b81d9ac7ef8b3f2f28af9e5f28d0956706f59a74367898c53 WHIRLPOOL 3c972f937afd76f5a4595bcee7cb3355a52a2d596615c2f7c3232d472e3b838b72547a4d5216c489f62d02fd3d96b6672b7d044aa2c39fa707f940469ea35554
diff --git a/dev-php/adodb/adodb-5.18.ebuild b/dev-php/adodb/adodb-5.18.ebuild
new file mode 100644
index 000000000000..fa6c42d2b4ab
--- /dev/null
+++ b/dev-php/adodb/adodb-5.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MY_PV=$(delete_all_version_separators "${PV}" )
+DESCRIPTION="Active Data Objects Data Base library for PHP"
+HOMEPAGE="http://adodb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adodb/adodb-php5-only/${PN}-${MY_PV}-for-php5/${PN}${MY_PV}a.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${PN}"$(get_major_version)
+DOCS="license.txt readme.txt xmlschema.dtd session/adodb-sess.txt pear/readme.Auth.txt docs/*htm"
+
+pkg_setup() {
+ ewarn "ADODB requires some form of SQL or ODBC support in your PHP."
+}
+
+src_install() {
+ # install php and xsl files
+ dodir "/usr/share/php/${PN}"
+ find . \( -name '*.php' -o -name '*.xsl' \) -exec tar -c '{}' \+ \
+ | tar -x -C "${D}/usr/share/php/${PN}"
+
+ default_src_install # copy DOCS
+}
diff --git a/dev-php/adodb/metadata.xml b/dev-php/adodb/metadata.xml
new file mode 100644
index 000000000000..47729dbb3dd7
--- /dev/null
+++ b/dev-php/adodb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="sourceforge">adodb</remote-id>
+ </upstream>
+</pkgmetadata>