summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 13:13:17 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:53 +1300
commitd7615016fe0e631fb9ae47b0d1d0d71fecd92741 (patch)
tree22ceead019f8026db237813cc6fee7df8cede264 /dev-perl/Specio
parentdev-perl/Date-Manip: Bump to version 6.560.0 (diff)
downloadgentoo-d7615016fe0e631fb9ae47b0d1d0d71fecd92741.tar.gz
gentoo-d7615016fe0e631fb9ae47b0d1d0d71fecd92741.tar.bz2
gentoo-d7615016fe0e631fb9ae47b0d1d0d71fecd92741.zip
dev-perl/Specio: Added at 0.310.0
Required in multiple ways by newer DateTime module Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Specio')
-rw-r--r--dev-perl/Specio/Manifest1
-rw-r--r--dev-perl/Specio/Specio-0.310.0.ebuild40
-rw-r--r--dev-perl/Specio/files/Specio-0.31-installskip.patch52
-rw-r--r--dev-perl/Specio/metadata.xml44
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-perl/Specio/Manifest b/dev-perl/Specio/Manifest
new file mode 100644
index 000000000000..6465155bdb93
--- /dev/null
+++ b/dev-perl/Specio/Manifest
@@ -0,0 +1 @@
+DIST Specio-0.31.tar.gz 82791 SHA256 ef4a7c4856032cb1d725f96c06de2a25d1edaef8812c1f86d13e55ecee0183f9 SHA512 1d16ff9aeb3e2026c23928db64587e42f74b2488b7aeef6ee7b03ec0542dd4986cca25b3206d7d50e54724d5d3e04e8ab268808d42ff32f179ea719ca6821544 WHIRLPOOL f81df5c29ca77c97541ab584ff3dd51c39d49c164fe8aae4bec52262ac4805d0cef273708004d695670abe32dd02b893fef773a49922b1677a2540e4f252ec9b
diff --git a/dev-perl/Specio/Specio-0.310.0.ebuild b/dev-perl/Specio/Specio-0.310.0.ebuild
new file mode 100644
index 000000000000..4e6705be3696
--- /dev/null
+++ b/dev-perl/Specio/Specio-0.310.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Type constraints and coercions for Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=("${FILESDIR}/${PN}-${DIST_VERSION}-installskip.patch")
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Devel-StackTrace
+ dev-perl/Eval-Closure
+ virtual/perl-Exporter
+ virtual/perl-IO
+ dev-perl/MRO-Compat
+ >=dev-perl/Role-Tiny-1.3.3
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-parent
+ >=virtual/perl-version-0.830.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Needs
+ )
+"
+mydoc="TODO.pod"
diff --git a/dev-perl/Specio/files/Specio-0.31-installskip.patch b/dev-perl/Specio/files/Specio-0.31-installskip.patch
new file mode 100644
index 000000000000..1798d3f0c2c7
--- /dev/null
+++ b/dev-perl/Specio/files/Specio-0.31-installskip.patch
@@ -0,0 +1,52 @@
+From 75ac71299516640967a884f58c1c0f9176fdb16f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 11 Nov 2016 12:43:36 +1300
+Subject: [PATCH] Mark TODO.pod as "Not for installation"
+
+https://github.com/houseabsolute/Specio/pull/4
+
+Due to historical reasons, EUMM installs all files called "*.pm"
+or "*.pod" in the distributions root directory to the the install
+target.
+
+For instance,
+
+ Dist-Foo-Bar/Bar.pm -> ${site_lib}/Dist/Foo/Bar.pm
+ Dist-Foo-Bar/TODO.pod -> ${site_lib}/Dist/Foo/TODO.pod
+ Dist-Foo/TODO.pod -> ${site_lib}/Dist/TODO.pod
+ Dist/TODO.pod -> ${site_lib}/TODO.pod
+
+INSTALL.SKIP is used by ExtUtils::Install to mark things as "not for
+installation" while performing "make install", and acts to filter
+things in "blib/" from landing in ${site_lib}
+
+It will still *appear* to have no impact because EUMM will still spit
+out that its copying it from Dist-Foo/ to Dist-Foo/blib/
+
+But it shouldn't end up in the install target.
+
+Additionally, this rule filters out any resulting man-pages as well,
+because TODO.pod will be manified before ExtUtils::Install gets a
+chance.
+
+And the proof is in the pudding.
+
+ cpanm -l /tmp/elib Specio-$VERSION.tar.gz
+ find /tmp/elib | grep -i TODO
+
+Now should emit nothing.
+---
+ INSTALL.SKIP | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 INSTALL.SKIP
+
+diff --git a/INSTALL.SKIP b/INSTALL.SKIP
+new file mode 100644
+index 0000000..5d454a6
+--- /dev/null
++++ b/INSTALL.SKIP
+@@ -0,0 +1 @@
++TODO\.(pod|0)$
+--
+2.10.2
+
diff --git a/dev-perl/Specio/metadata.xml b/dev-perl/Specio/metadata.xml
new file mode 100644
index 000000000000..270851de65e0
--- /dev/null
+++ b/dev-perl/Specio/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Specio</remote-id>
+ <remote-id type="cpan-module">Specio</remote-id>
+ <remote-id type="cpan-module">Specio::Coercion</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::AnyCan</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::AnyDoes</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::AnyIsa</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Enum</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Intersection</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::ObjectCan</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::ObjectDoes</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::ObjectIsa</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Parameterizable</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Parameterized</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Role::CanType</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Role::DoesType</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Role::Interface</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Role::IsaType</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Simple</remote-id>
+ <remote-id type="cpan-module">Specio::Constraint::Union</remote-id>
+ <remote-id type="cpan-module">Specio::Declare</remote-id>
+ <remote-id type="cpan-module">Specio::DeclaredAt</remote-id>
+ <remote-id type="cpan-module">Specio::Exception</remote-id>
+ <remote-id type="cpan-module">Specio::Exporter</remote-id>
+ <remote-id type="cpan-module">Specio::Helpers</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Builtins</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Numeric</remote-id>
+ <remote-id type="cpan-module">Specio::Library::Perl</remote-id>
+ <remote-id type="cpan-module">Specio::Library::String</remote-id>
+ <remote-id type="cpan-module">Specio::OO</remote-id>
+ <remote-id type="cpan-module">Specio::PartialDump</remote-id>
+ <remote-id type="cpan-module">Specio::Registry</remote-id>
+ <remote-id type="cpan-module">Specio::Role::Inlinable</remote-id>
+ <remote-id type="cpan-module">Specio::TypeChecks</remote-id>
+ <remote-id type="cpan-module">Test::Specio</remote-id>
+ </upstream>
+</pkgmetadata>